Jump to content
Welcome to our new Citrix community!
  • 0

Norskale Agent Host Service - STOP


Question

Hi everyone,

 

I'm doing a POC with a client, where make a server provisioned by MCS (XD 7.13) with WEM 4.3 installed. In AIO environment.

 

 

I read the need for refresh cache, start norskale agent service and netlogon service. And because of that i did the following startup script for that:

 

 

@Echo off
@REM Restarting services.
"C:\Program Files (x86)\Norskale\Norskale Agent Host\AgentCacheUtility.exe" -RefreshCache
ping -n 15 lmnvdi01.cerrejon.com > nul
net start "Norskale Agent Host Service"
ping -n 15 lmnvdi01.cerrejon.com > nul
net start "netlogon"

 

It appear to work well, but Norskale Agent Host Service and netlogon stopped 3 times with no one explanation.

 

I found this information in Application Event Viewer:

 

 

 

The description for Event ID 0 from source Norskale Agent Host Service cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
 
If the event originated on another computer, the display information had to be saved with the event.
 
The following information was included with the event: 
 
Service stopped successfully.
 
The handle is invalid

 

In the same way I found this in System log:

 

The description for Event ID 7036 from source Service Control Manager cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
 
If the event originated on another computer, the display information had to be saved with the event.
 
The following information was included with the event: 
 
Netlogon
stopped
 
The handle is invalid

 

 

And this one:

 

The description for Event ID 7036 from source Service Control Manager cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
 
If the event originated on another computer, the display information had to be saved with the event.
 
The following information was included with the event: 
 
Norskale Agent Host Service
stopped
 
The handle is invalid

 

 

Can you help me with this?

Thank you so much,

 

 

Link to comment

8 answers to this question

Recommended Posts

  • 0

now, I trying with GPO, but it's not working too..

 

 

Computer Configuration > Preferences > Windows Settings > Services

 

Startup: Automatic

Service name: Norskale Agent Host Service

Service action: Restart service

Local System account

 

 

Startup: Automatic

Service name: netlogon

Service action: Restart service

Local System account

 

 

I'd try too with "service action: start service" and doesn't work.

 

 

 

Computer Configuration > Preferences > Windows Settings > Scheduled Tasks

 

Action: Update

Name: refresh agent cache
Run: "C:\Program Files (x86)\Norskale\Norskale Agent Host\AgentCacheUtility.exe"
Arguments: -RefreshCache
 
Tick on "Enabled"
 
Schedule > At System Startup
 
I really don't know what I'm doing wrong. Because the servers in the PoC after a reboot need manually reset the Norskale Agent Host Service manually. And never synchronize properly, always show like sign of question.

 

Thank you,

Link to comment
  • 0

I'm having the same issue as well but only on Server 2016 patched with latest June 2017 updates. But in my case I'm using PVS instead of MCS, and I have the WEM Agent in a layer using Unidesk v4.2. I'm able to get it to work using Windows 10 and the same setup.

 

I create a script, that I have running at system startup through Task Scheduler. That does the same thing your script does, basically.

 

net stop "Norskale Agent Host Service" /y
net start "Norskale Agent Host Service"
net start "Netlogon"
"C:\Program Files (x86)\Norskale\Norskale Agent Host\AgentCacheUtility.exe" -refreshcache
 
Using this same configuration in Windows 10 works, and the agent starts at boot time and the WEM cache updates and the agent is available at first log on.  Maybe it's an issue between the agent and the Server 2016 OS.  I haven't dug deep enough into the logs to troubleshoot but I'll rebuild the image and see if my logs say something similar.
  • Like 2
Link to comment
  • 0

Thank you Cedric, I'll try your script. I can see you restarts the services before refresh the cache. It can be the solution.

 

Following my investigation, now I found this events in "Applications and Services Logs > Citrix > Norskale Agent Service"

 

 

Source: Norskale Agent Service

Level: Warning: 

Event ID: 0

 

Agent Service Broker Connection Timeout Reached

 

 

 

And this one:

 

 

 

Source: Norskale Agent Service

Level: Warning: 

Event ID: 0

 

Agent Host detected as offline -> Exiting Local Cache Synchronization

 

 

 

 

 

Thank you !

Link to comment
  • 0

Ok, I've been able to deploy this successfully twice to brand new VMs.

 

To execute the script, I used Task Scheduler @ Startup first. But, after looking at logs and services, the Norskale service would start and then stop a few moments later, and remain stopped, thus the Agent not working at first logon.  The Task executed before the Norskale service even began natively through Windows services.

 

So I changed the script around to

@echo off
call net stop "Norskale Agent Host Service"
call net start "Norskale Agent Host Service"
call "C:\Program Files (x86)\Norskale\Norskale Agent Host\AgentCacheUtility.exe" -refreshcache

 

and saved it as RefreshWEMCache.cmd file to a local location C:\Windows\setup\scripts in my case since in using AppLayering.

 

I then used gpedit.msc for the local machine, and set the RefreshWEMCache.cmd to run as a startup script.

 

From fresh images, and fresh PVS targets. I see the device register with WEM at boot time, and when I first log in the WEM agent is running succcessfully. UPM profile creations and all which I have going through WEM.

 

Try this and let me know, how that works out.

Link to comment
  • 0

Hi Cedric, 

 

I modify the commands to auto accept the call to stop dependencies also, with "/y" argument.

 

 

@echo off
call net stop "Norskale Agent Host Service" /y
call net start "Norskale Agent Host Service"
call "C:\Program Files (x86)\Norskale\Norskale Agent Host\AgentCacheUtility.exe" -RefreshCache

 

 

And it's look works fine now, I will put it under 2 or 3 days of testing and I'll go back with news.

 

Thank you a lot for the help !

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...