Jump to content
Welcome to our new Citrix community!
  • 0

Enable Single Sign-On in Desktop Director not working from another machine


Cloud Mercury

Question

I have configured director according to Citrix  Director Documentation and used the Carl Stalhood forum for Director Singel Sign-On

 

When I browse the url https://directorserver.company.com/director right on the director machine, the SSO works perfectly, but when I come from client machine than the SSO doesnt work.

 

I have also done setspn -S https/directorserver.company.com/director on the director server but no success.

 

Is there any solution to this probleem. I would be thankful for that.

Link to comment

2 answers to this question

Recommended Posts

  • 0

Hi Cloud, 

 

There isn't really much to go on in your description of the issue. ;)

 

Are you getting any errors on the client machine? Check the event viewer on the client and on the director server for clues.  

 

You can also review the IIS logs on the director server for clues:

 

https://support.citrix.com/article/CTX130320

 

 

There are considerations when a NS is involved and there are many factors at play that could be misconfigured.

 

If you cannot find any errors or additional clues, AND have fully and correctly executed all the steps in the two articles you have linked to, then it would be a good idea to create a support case for this so we can review the issue in detail. 

Link to comment
  • 0
On 5/18/2017 at 9:32 PM, Cloud Mercury said:

I have configured director according to Citrix  Director Documentation and used the Carl Stalhood forum for Director Singel Sign-On

 

When I browse the url https://directorserver.company.com/director right on the director machine, the SSO works perfectly, but when I come from client machine than the SSO doesnt work.

 

I have also done setspn -S https/directorserver.company.com/director on the director server but no success.

 

Is there any solution to this probleem. I would be thankful for that.

Known issue in the support community.  Unacknowledged by Citrix, which is shame, as am sure they could fix it.  n.b. your SPN cmd should be 

setspn -S http/directorserver.company.com accountname

where accountname is by default the computer object, else the custom account of the app pool (and if kernel mode auth disabled), but it won't matter, bug in Director.  

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...