Jump to content
Welcome to our new Citrix community!
  • 0

Key icon displayed when logging into Xendesktop?


Stephen D. Holder

Question

21 answers to this question

Recommended Posts

  • 2

Okay got to the bottom of this one after recutting images and trolling group policy. Note I did not have any success setting the following policy option to not configured in a version be it either MCS or PVS. This worked for a fresh image and a static mcs image.

https://docs.microsoft.com/en-us/windows/security/threat-protection/security-policy-settings/interactive-logon-do-not-display-last-user-name

Set that to not configured accross images or possiby enabled, but dont set to disabled and then enabled. I cant explain it but as soon as I stopped applying it to my static mcs images following a reboot I got the sensible user icon back. However when i stopped applying it in a version (be it pvs or mvs) it wouldnt work.

I hope this helps someone!

  • Like 3
Link to comment
  • 1

Yeah read above, I have fixed the blue keys issue across 3 different environments for a customer. Its the group policy option "do-not-display-last-user-name" at logon. If this was ever set to enabled and applied to an image you cant remove t  he keys image, even if you set it to not configured or disabled.

I would recommend rebuilding your image in a staging OU with this policy not applied.

  • Like 1
Link to comment
  • 0

ok...so interesting tidbit...

 

I've been doing some testing on another image since I wasn't having the problem with my 2016 build.  I noticed that before my mcs machines registered with WEM the problem was not there.  Once they got the WEM config its a problem now on this second image.  I was ready to place blame on the optimization tool as I've seen weird problems with it before but I haven't yet run it on the new image.

 

I can't see much of anything that should be causing it based on the WEM config.  I'm using a pretty standard/basic setup and its almost identical on 2016 with the exception of some of the cpu optimization settings.

Link to comment
  • 0

In my original post, everything was base isos -- no WEM or other optimizations were applied. Just windows updates. At the time, I didn't have 2016, so my build was based on Win10, although can't recall the version. But considering other folks are having the same issue with v1709 and higher, it may not matter and the issue still may exist.

 

I believe the only extra element I had running during this time was App Layering - but it's been a while so I can't be certain.

 

If you all who are having the issue can chime in as to if you are or are not using app layering with your desktops -- maybe that can fit in another piece of the puzzle?

Link to comment
  • 0

Interesting info here, I am not using WEM and am having the issue in multiple environments, however when you mentioned optimisations, I realised I have applied the Citrix Optimizer tool across all environments. I decided to deploy 1809 against 7.17 with and without the optimizer tool and unfortunately no keys icon haha. The plot thickens, Maybe its the raft of Microsoft group policy applied in my production environments. Will continue to investigate.

 

 

Link to comment
  • 0

I'm coming up against this issue too with Windows 10 in a PVS image. while its not a big problem it looks horrible. With windows 10 the "dont display last user" fix doesn't appear to be quite the full story at the moment as I'm still getting it with that policy unconfigured in local and AD Policies. What I did find though is that when installing windows 10 Microsoft applies a default set of local security policies whether you want them or not. The template it seems to take these settings from is in %windir%\inf\defltbase.inf this also contains the "dont display" setting. To get round that I mounted the wim file with DISM and commented out the setting directly after taking ownership of the file and then redeployed the image. So this should make sure that the setting has never been configured to anything which is suggested as a problem in this thread above within this version of the image.

 

However I'm still getting the ugly blue key, so not a fix but possibly something that windows 7 doesn't do. Guess its back to the drawing board and keep on digging for the answer as this key is cropping up in several customers environments and at some point someone is going to complain about it.

Link to comment
  • 0

I have a customer who is experiencing the same problem as we discuss here. 

Has anyone finally found the root cause of the problem? How to fix it?

 

Phenomenon:  Key Image displayed during ICA session login on Windows 10 VDIs

Environment:
    -XenDesktop Version: 7.15CU5
    -Master Image OS: Windows 10 1803
    -VDA Version: 7.15CU5
    -Hypervisor: VMware VSphere 6.5
    -Provisioning Method: PVS 7.15Cu5

Link to comment
  • 0

Anyone figure this one out?  have the same problem with a client I am working with.  New Windows 10 build running VDA 1912.  PVS also but also occurs on persistent Win10 machines.   Have tried removing the registry keys associated with interactive logon: Don't display username or user ID but still happens.  Am trying 1912 CU1 but don't hold out much hope. 

Link to comment
  • 0

I know this is an old thread, but I had this problem recently, and it turns out that this "blue key" screen appears only if you log on within a short period of time after the provisioned machine boots. Set the Delivery Group to "reboot on logoff" to False, and you will probably see it go away. I was tearing my hair out for days on this, and it seems the resolution is simply to wait. Must be something to do with GPO processing time.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...