Jump to content
Welcome to our new Citrix community!
  • 0

you have not chosen to trust "thawte premium server CA", the issuer of the server's security certificate

John Castillo


Hi All,


We need help in one of our MAC connecting to our work network using citrix receiver 12.5


Mac OS X El Capitan V 10.11.6

citrix receiver 12.5


I actually found one solution for this problem under this article https://support.citrix.com/article/CTX108800&se but didnt work.


but the problem is X509 Anchors Keychain is missing in the keychain tried to add it but the certificate is not validated. anyone experience this problem? 


Hopefully someone know how to fix this. thank you in advance.




Link to comment

4 answers to this question

Recommended Posts

  • 0


ran into the same issue today. here is how I fixed it on my Mac with OS X Sierra 10.12.3


Download the missing certificate:



Double click the .pem file and add it to your System keychain.  Open keychain app and search for the certificate. Double click it and change the settings to "always trust".  Enter your password when asked to.


Now it should work :)

Link to comment
  • 0

Hi, I am on OSX Sierra 1.12.6 

Citrix Receiver 12.9.1 (56)


and I am seeing the same issue. Exact message is:


"you have not chosen to trust thawte rsa ca 2018 the issuer of the server's security certificate"


None of the mentioned links help.


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...