Jump to content
Updated Privacy Statement
  • 0

Black square around cursor with GRID


Eric Rottier

Question

Hi all,

 

We have a problem with a black square around a cursor in graphical applications like SketchUp and Photoshop. <See attachment>

 

All I can find is that the issue was known before VDA 7.6, and fixed in 7.6. But it seems it's back...

(source 1, source 2 and more I cannot find atm.)

 

The environment:

  • XenServer 7.1 (7.0 has the same error) with Nvidia GRID K2 (K240Q, 1GB profile)
  • Newest NVidia drivers on the XenServer and XenDesktop.
  • XenDesktop:
    • DDC: 7.13
    • VDA: 7.13, HDX 3DPro + NVENC (hardware acc - on)
    • Fresh installed Windows 10, 1607.1, fully patched

The problem only occurs on Receiver for Linux (13.4.2) machines. We have around 90% HP ThinPro T630's. Receiver 13.5 also does not fixes it.

 

A interesting detail is the HDX monitor. The Graphics - Thinwire states: Component_Capabilities_Cursor32BitsSupport: False.

On Receiver for Windows machines, where the cursor behaves normally, this is set to True.

I do not know how to influence this.

 

Options I tried:

  • Receiver for Windows does not have this problem
  • Two different freshly installed XenServer machines produce the same result
  • Session resized
  • Session reconnection (also to a Windows client, which is good, then back to Linux and it's bad again)
  • Cursorshadow off (was already off, tried turning it on to no avail ofc)
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\HDX3D
    • HKLM_CatiaV6Cursor (should not work after XD 5.6 anyway)
    • EnableUnknownCursorHandling set to 1
  • Set DisableXRender=1 in wfica.ini in the Linux client
  • Changed mouse pointer schema in client and XenDesktop
  • More I already forgot

 

The reason we have the latest version of everything is because the issues we had before. The most annoying was the constant session (client) freezing while the session worked fine in the background. So it's unfortunately not really an option to go back.

 

I personally think the ¨Cursor32BitsSupport¨ set to false is the thing I'd like set to true, but I cannot find any option to toggle it anywhere.

 

I hope anyone has more bright idea's :)

 

Thanks!

post-7964809-0-05550300-1490281945_thumb.jpg

Link to comment
  • Answers 59
  • Created
  • Last Reply

Recommended Posts

I don't think it's related to AMD CPU. We run about 50 HP t630 thin clients.

Also made a VM with Debian 8, installed the newest Citrix Receiver for Linux 13.6 and VDA 7.15

 

Next was a Chromium live usb on a laptop, no luck.

 

Since there is a parameter on the Linux Thin Client ¨Cursor32BitsSupport¨ which is set to False.

The VDA should 'listen' to that and NOT send the cursor 32 bits, but 24 bits as it did before.

Setting it to True doesn't really change the capabilities of the ThincClient (receiver).

 

So I do think it's considered a bug in VDA. "Not considering the 'Cursor32BitsSupport' setting"

 

 

This is so disturbing daily work that my colleagues are asking "Please NO Citrix for me!"

 

 

 

 

 

post-12560127-0-28744700-1504951946_thumb.jpg

post-12560127-0-70021400-1504951954_thumb.jpg

post-12560127-0-76235400-1504951969_thumb.jpg

Link to comment

I want to add it's the Workstation OS VDA 7.15, running on Windows 10 Enterprise 10 N 2016 LTSB, that's showing this black square.

 

The Server OS VDA 7.15, running on Windows Server 2016, does NOT show the black box.

 

Also attached two screenshots of the Citrix HDX Monitor 3.5.2 which show the Cursor32BitsSupport parameter on a Windows client and a Linux client.

 

post-12560127-0-45729700-1505304998_thumb.png

 

post-12560127-0-06817000-1505305008_thumb.png

 

 

Mark

Link to comment

Was told a little over a month ago by a Citrix rep that support for 32bit cursors would be 100% included in the 13.7 release of the linux receiver. Just tested it out and it still doesn't work and there is no mention of it in the release notes. It is already supported on the windows and mac receiver, I really don't understand why they are shunning the linux one. This is a huge issue for anyone using HDX3DPro since most users that utilize this most likely are using programs like Revit, Sketchup, and Adobe products. I don't get how they would change XenDesktop/XenApp to support 32bit cursors but then not make sure all of the receivers support it as well. Guess i'll re-open that ticket but since they consider this a feature request and not a bug/issue don't know what it will really do... 

Link to comment

Unfortunately, I need to confirm that version 13.7 does not solve the problem.

Calling 32 bits cursor  support a new feature and not a bug, okay with me.

 

But not having an 'escape / fall back' 24 bits cursor for devices that report Cursor32BitsSupport=FALSE.

I would call that a bug in the feature.

 

We're now testing moving away from XenDesktop.

Link to comment

We too are experiencing this issue since moving our GRID enabled environment to Windows 10 1607 14393.1770 with LTSR VDA 7.15.1000 HDX 3D Pro enabled.  This does not happen in our GRID Win 7 VDA 7.6.1000 HDX 3D Pro enabled machines.  We are using Linux IGELs and HPs in our company and it's happening to both.  As previously described it works fine on Windows and Mac receivers.  Just wanted to add my name to the list of people waiting for the fix!

 

EDIT: I just noticed a new Linux Receiver 13.8 released very recently.  Has anyone had a chance to try it out and see if it fixes this issue?

Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...