Jump to content
  • 0

Cannot receive data in Citrix DesktopReceiver


Jens Strohschnitter1709152492

Question

Hi there,

 

we are running XenDesktop 7.6 LTSR CU3. In DesktopDirector we get the following error on
"details" tab:

 

 

Personalization

Cannot retrieve the data.   Unexpected server error. View Director server event logs for further information (Refer Citrix KB article CTX130320). 

 

We've configured IIS as described in CTX130320. But no data will be showen.

 

Does this work only on platinuum editions ? We are running enterprise edition.

 

Kind regards

Jens

Link to comment

7 answers to this question

Recommended Posts

Hi Jens, 

 

Can you run the following command from PowerShell on your VDAs and check if you receive the data ? 

Get-wmiobject -Class LogonTimings -Namespace "Root\Citrix\profiles\metrics"

 

If you don't get any data, try to repair UPM WMI by running the below commands on VDAs and check again.  

 

For X64:

 

C:\Windows\Microsoft.NET\Framework64\v4.0.30319\installutil.exe %ProgramFiles%\Citrix\Virtual Desktop Agent \upmWmiMetrics.dll

 

C:\Windows\Microsoft.NET\Framework64\v4.0.30319\installutil.exe %ProgramFiles%\Citrix\Virtual Desktop Agent \upmWmiAdmin.dll

 

For X86:

 

C:\Windows\Microsoft.NET\Framework\v4.0.30319\installutil.exe %ProgramFiles%\Citrix\Virtual Desktop Agent \upmWmiMetrics.dll

 

C:\Windows\Microsoft.NET\Framework\v4.0.30319\installutil.exe %ProgramFiles%\Citrix\Virtual Desktop Agent \upmWmiAdmin.dll

 

 

 

Thank you! 

Krishna 

Link to comment

Thank you,

 

sorry for my late reply, I was on vacation.

 

1) Yes we are using Citrix UPM in Version 5.7

2) Get-wmiobject showes no content

3) Reinstalling DLL's via installutil

4) Get-wmiobject showes no content again

5) Added the DLL's Installation on boot-script

6) Still no data

7) Reinstalled the UPD_VDAplugin_x64.msi

8) Reinstalled DLL's via isntallutil

 -> still no data

 

Also on Director's Dashboard there is no avarage logon duration available.

 

Attached two screenshots with WMIExplorer (1_no_pvs and 2_with_pvs)

 

Kind regards

Jens

 

 

Kind regards

Jens

post-10911008-0-97736900-1489410336_thumb.png

post-10911008-0-93846900-1489410345_thumb.png

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...