Jump to content
Updated Privacy Statement

StoreFront 3.5 - Get rid of Receiver detection "Welcome to Citrix Receiver"-Screen


Michael Weishaar

Recommended Posts

Hello Community,

 

 

How can I get rid of the Citrix Receiver detection when a user opens StoreFront Web (connecting through NetScaler Gateway) for the first time? (see attached screenshot)

I want users to always use clientless per default if no local receiver is detected.

 

In StoreFront configuration the option "Use Receiver for HTML5 if local Receiver is unavailable" is selected.

 

 

Best Regards,

Michael

post-12567449-0-14796400-1487252109_thumb.jpg

Link to comment
Share on other sites

The problem is that Receiver can only be auto-detected in IE. All other browsers require a user action so Receiver can be detected. For example, in Chrome, the user has to click the blue Detect Receiver button so Receiver can detected. If Receiver is not detected, then HTML5 Receiver will always be used.

 

In the StoreFront console, there is a checkbox for "Allow users to download HDX engine (plug in)"

Link to comment
Share on other sites

Thanks Carl for yours answer. I don't want to see the screen at all if a user logs in. Is it possible to disable it?

 

Background: Not all users have a local receiver installed (and they don't need it to access e.g. a RDP session). They get confused if they were prompted to install a software (which they can't do anyway because lack of administrative permissions on their client).

Link to comment
Share on other sites

My browsers still ask to install receiver (IE, Edge, Chrome, Firefox). Configuration:

 

<pluginAssistant enabled="false" upgradeAtLogin="false">
          <win32 path="http://downloadplugins.citrix.com/Windows/CitrixReceiverWeb.exe" />
          <macOS path="http://downloadplugins.citrix.com/Mac/CitrixReceiverWeb.dmg"
            minimumSupportedOSVersion="10.6" />
          <html5 enabled="Always" platforms="Firefox;Chrome;Version/([6-9]|\d\d).*Safari;MSIE \d\d;Trident/([6-9]|\d\d);Android;iPad;iPhone;iPod;"
            launchURL="clients/HTML5Client/src/SessionWindow.html" preferences=""
            singleTabLaunch="false" chromeAppOrigins="chrome-extension://haiffjcadagjlijoggckpgfnoeiflnem"
            chromeAppPreferences="" />
          <protocolHandler enabled="false" platforms="(Macintosh|Windows NT).*Chrome/((4[2-9]|[56789][0-9])|\d\d\d)(?!.*Edge)"
            skipDoubleHopCheckWhenDisabled="false" />

</pluginAssistant>

 

 

I restarted IIS after changing the file.

 

EDIT:

Interesting: When using iOS, NetScaler/StoreFront is not asking for receiver.

Link to comment
Share on other sites

  • 1 year later...

The issue is still present using StoreFront 3.12.1000 and NetScaler 12.0 Build 57.19

 

IE/Edge: No prompt to detect receiver when connecting directly to StoreFront and through NetScaler

Chrome/Firefox: No prompt to detect receiver directly to StoreFront but prompt when connecting through NetScaler

 

Opened Cases:

 

Case #76628696 (NetScaler Team)

Case #76630996 (StoreFront Team)

 

Best Regards,

Michael

Link to comment
Share on other sites

  • 4 months later...
  • 6 months later...
On 28/07/2018 at 1:34 PM, Sergiu-Konrad Kork said:

Don't know if you fixed it, but in SF 3.x you need to disable the protocol handler for Firefox & Chrome, as Vignesh stated above.

Once that is done, no more detection in either browser  - just tested.

 

I was facing this issue that my NS wasn't delivering properly my Virtual Server on the netscaler gateway session profile. 

I finally solved this problem following this article https://support.citrix.com/article/CTX209283

I've got SF 3.12.2000.8 and NS NS12.0 53.13.nc

Link to comment
Share on other sites

  • 3 months later...

I am having the opposite problem.  I have random users in different browsers and different OSes that are unable to get the Receiver detection to work and are stuck using the HTML5 Receiver.  We only need the HTML5 receiver for a handful of users and the rest prefer to use the full client.  Any thoughts as to what settings in the browser might be blocking the Receiver detection in the browser.  I have confirmed that the detection is enabled in the web.config in storefront and the detection works for me in IE11, FF, and Chrome on Windows 10

Link to comment
Share on other sites

  • 9 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...