Jump to content
Welcome to our new Citrix community!
  • 0

Why is Java not properly reading deployment.config file??


Tom Lyczko

Question

We have a 4-server XenApp farm on Win2k8 R2.
All the servers have Java installed on them.

I read all the numerous instructions about how to put deployment.config into C:\Windows\Sun\Java\Deployment on each RDS 
server and deployment.properties and exception.sites into an accessible network share, referred to in deployment.config and exception.sites, respectively.

deployment.config says:

deployment.system.config=file\://server/software/java_files/deployment.properties
deployment.system.config.mandatory=true

deployment.properties says:

deployment.webjava.enabled=true
deployment.security.level=HIGH
deployment.security.level.locked
deployment.expiration.check.enabled=false
deployment.user.security.exception.sites=file\://server/software/java_files/exception.sites

exception.sites contains just one website URL

What is happening and I don't understand why, is the users start Java and they get a deployment.properties file created in the 
XenApp server's local user profile in C:\Users\username\AppData\LocalLow\Sun\Java\Deployment...which does not even have the desired deployment properties nor the exception.sites involved.

HOW do I get Java to work as it's supposed to?? -- read the deployment.config and use the referenced deployment.properties file??

What is causing Java to not read the deployment.config file and then not know about the other two files??

In other words upon going to the site in the exception.sites list, Java still asks for permission to run the applet.

Java is creating its own deployment.properties file instead of reading anything from the custom file.

 

Thank you, Tom

Link to comment

6 answers to this question

Recommended Posts

  • 0

Tom,

 

This is how I am configuring this:

 

C:\Windows\Sun\Java\Deployment\Deployment.config

deployment.system.config=file:\\\\server\share\\deployment.properties
deployment.system.config.mandatory=true
 
\\server\share\deployment.properties
#deployment.properties
 
# Certificate Stores and Policy Settings
deployment.user.security.exception.sites=\\\\server\\share\\\\exception.sites
deployment.user.security.exception.sites.locked
deployment.security.level=HIGH
deployment.security.level.locked
 
# Disable the prompt asking users to update JAVA
deployment.expiration.check.enabled=false
deployment.expiration.check.enabled.locked
 
# Java Web Start Configuration
# Disable icons from being created
deployment.javaws.shortcut=NEVER
deployment.javaws.shortcut.locked
 
# Cache Configuration
deployment.cache.max.size=0
deployment.cache.jarcompression=9
 

 

\\server\share\Exceptions.sites

http://site1.com

http://site2.com

http://site3.com

 

 

 

I hope that helps you get your deployment working.

Link to comment
  • 0

I redirect to a local "D" drive. my depoyment.config 

 

deployment.config consists of:
deployment.system.cachedir = D\:\\JavaCache\\
deployemtn.system.config = file\:\\C\:\\WINDOWS\\Sun\\Java\\Deployment\\deployment.properties
deployment.system.config.mandatory = true

 

deployment.properties

#System Deployment Properties
#Mon Jun 13 09:40:55 CDT 2016
deployment.security.level-Medium=
javaplugin.cache.size=10m
deployment.user.cachedir=D\:\\JavaCache\\
javaplugin.cache.directory=D\:\\JavaCache
deployment.javaws.autodownload=NEVER
deployment.user.security.exception.sites=C\:\\Windows\\Sun\\Java\\Deployment\\exception.sites
deployment.system.cachedir=D\:\\JavaCache\\
javaplugin.console=hide
deployment.expiration.check.enabled=false
Link to comment
  • 0

I got to talk about this with Kronos tech support awhile ago and received a lot of specific good technical advice on this.

I learned about the caching ability of Java and will set this up.

I am setting things up now for someone else to come in and approve everything into the cache.

I will update later this week or next week.
Thank you, Tom

Link to comment
  • 0
On 12/14/2016 at 10:35 PM, Tom Lyczko said:

I got to talk about this with Kronos tech support awhile ago and received a lot of specific good technical advice on this.

I learned about the caching ability of Java and will set this up.

I am setting things up now for someone else to come in and approve everything into the cache.

I will update later this week or next week.
Thank you, Tom

 

Hey Tom, do you remember what you had to do here to get this to work? I am facing a similar problem right now and cant seem to figure out why Java does not like my config/properties files.

Thanks.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...