Jump to content
Welcome to our new Citrix community!
  • 0

PVS Streaming Speed


Tim Wolf1709152741

Question

Hi guys

 

I just did some performance tests with my PVS 7.9 environment and found that PVS seems to stream very slow compared to traditional copying.

I wonder if this is as usual or if there is a way to optimize my PVS.

 

I've already tried to tweak my PVS settings (MTU, I/O burst etc.) but without much change in speed. The vDisk is merged and optimized. TCP Large Send Offload is disabled.

 

Host (XenServer 7.0 Patchlevel up to XE07E012)

 

PVS Server (2012R2 + PVS 7.9)

20Gb/s

24GB RAM

SSD Local Storage

 

Target Device (WIN7/2012R2 + PVS Services 7.9)

20Gb/s

SSD Local Storage

 

Scenario:

copying the same files (3.6GB,33 Files,50-500MB each) to Target Device "real local drive"

 

75MB/s; from within vDisk vhdx Image when booted. (RAM Cache 6GB + Disk Cache 20GB)

300MB/s; from folder on PVS Server (same drive)

300MB/s; from mounted vDisk on PVS Server

 

So PVS seems to eat a lot of storage bandwidth compared to direct copy from PVS server.

Is this by design? What are you experiences?

 

 

Regards,
Tim

Link to comment

2 answers to this question

Recommended Posts

  • 0
On 10/18/2016 at 5:30 PM, Tim Wolf1709152741 said:

Hi guys

 

I just did some performance tests with my PVS 7.9 environment and found that PVS seems to stream very slow compared to traditional copying.

I wonder if this is as usual or if there is a way to optimize my PVS.

 

I've already tried to tweak my PVS settings (MTU, I/O burst etc.) but without much change in speed. The vDisk is merged and optimized. TCP Large Send Offload is disabled.

 

Host (XenServer 7.0 Patchlevel up to XE07E012)

 

PVS Server (2012R2 + PVS 7.9)

20Gb/s

24GB RAM

SSD Local Storage

 

Target Device (WIN7/2012R2 + PVS Services 7.9)

20Gb/s

SSD Local Storage

 

Scenario:

copying the same files (3.6GB,33 Files,50-500MB each) to Target Device "real local drive"

 

75MB/s; from within vDisk vhdx Image when booted. (RAM Cache 6GB + Disk Cache 20GB)

300MB/s; from folder on PVS Server (same drive)

300MB/s; from mounted vDisk on PVS Server

 

So PVS seems to eat a lot of storage bandwidth compared to direct copy from PVS server.

Is this by design? What are you experiences?

 

 

Regards,
Tim

 

 

Tim, did you ever get this resolved? We just migrated to a massive Dell EMC VXRail system on ALL FLASH, and unbelievably... I can get 2800 MB/s on all my servers EXCEPT my Citrix provisioned servers. When I'm inside the provisioned vhdx image (like you) my reads crawl ~100 MB/s, and writes are even worse at 23 MB/s; I may as well be running Citrix on a sh!tty jumpdrive or something!

 

Just curious if you found anything out (you posted a few years ago, and I know its a long shot)

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...