Jump to content
Welcome to our new Citrix community!

Http/1.1 Internal Server Error 43549 - Radius Timeout


Recommended Posts

Hi
I am using Netscaler VPX 11.0 63.16 with Storefront 3.6 behind.
I have setup smspasscode/Radius validation, but if the user is more than 3 minutes to enter the passcode(wrong or correct), then it goes to the page /cgi/dlge instead of going back to the login pages, and fails with error “Http/1.1 Internal Server Error 43549”. 
 
I have load balanced Storefront and Radius, and tried to set Persistence and Method if that would help.
Persistence: SOURCEIP, Time-out (mins), 60
Radius also have Method: Load Balancing Method: TOKEN, Expression: CLIENT.UDP.RADIUS.USERNAME
 
Guessing I have missed a 3min timeout somewhere, but do not know where?
 

Regards Denis

Link to comment
Share on other sites

  • 2 weeks later...

I have the same issue!
I've setup SMS Passcode to send the passcode via e-mail if the first passcode (via SMS) expires, which it does after 2 minutes.

When I get the passcode via e-mail (after waiting 2 minutes) and try to enter it I get the following error from the netscaler gateway:

"Http/1.1 Internal Server Error 43549"

Using Netscaler VPX 10.5, Windows NPS as a RADIUS server and Storefront 2.6.

 

Where is the time out setting that I need to change?

 

I assume you have a RADIUS policy on your NetScaler. That policy/server has a timeout field.

That is set to 3 seconds, isn't that timeout field defining how long NetScaler should try to connect to the RADIUS server before erroring out?

 

Regards

P-H

Link to comment
Share on other sites

  • 3 months later...
  • 1 year later...
  • 4 weeks later...
  • 1 year later...
  • 5 months later...

I'm not aware of any way round it. https://support.citrix.com/article/CTX236072 seems to contradict https://support.citrix.com/article/CTX201151, but it's one of those very low quality Citrix KB articles that looks like someone's personal notes rather than anything useful. Also, the maximum value for "NATPCB New Connection Idle Time-out" is 120 seconds.

 

I don't mind the timeout, but I do mind the poor UI where the user gets stuck on unfriendly page.

  • Like 2
Link to comment
Share on other sites

  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...