Jump to content
Welcome to our new Citrix community!
  • 0

XenApp 7.9 - there are no apps or desktops available to you at this time

Ike Kim1709151824




I just downloaded and got XenApp 7.9 installed, configured and published a application & desktop, however, when I get to the storefront I keep getting  "there are no apps or desktops available to you at this time". I tried different options on Delivery Group user settings but no luck.


This is all with Win 2012 R2 machines. I had XenApp 7.6 setup previously and had no problems.


What am I missing?






Link to comment

22 answers to this question

Recommended Posts

  • 0

I'm receiving this error "there are no apps and desktops available at this time" as well.  Checked the event logs on my storefront server and came across error "None of the Citrix XML Services configured for the farm controller are in the list of active services, so none were contacted". On my delivery controller, I ran brokerservice.exe /show and I got the following:


C:\Program Files\Citrix\Broker\Service>brokerservice /show
SDK Port: 80
VDA Port: 80
StoreFront Port: 80
StoreFront TLS Port: 443
Log File:


I don't see any Citrix XML service under services control manager. This was due to I had IIS running on my delivery controller which I've removed it now. Can someone help me with Citrix XML service which is missing and what needs to be done more in order to get rid of that error? I know changing transport type from https to http would probably fix it but I would like to use https instead. My SSL cert is working fine.



Link to comment
  • 0

I have the same issue with setup XenDesktop 7.17, here is the fix.

In Citrix Studio, Under Store services, click Configure Store Settings.

Under User Subscriptions, click Disable User Subscriptions (Mandatory Store).

It fixed the issue right away. 

(HTTP, HTTPS, XML bind etc all doesn't matter.)


Link to comment
  • 0

I'm seeing this as well and everything with SSL from cert to settings seems okay but I don't have the option to just flip to http over https. Thats fine for internal clients on the network but not external clients coming through the netscalers from outside the network, and yes https does not work for internal clients as well.

Link to comment
  • 0
On 9/16/2020 at 4:34 AM, Mohammed Shareef1709162282 said:


Thanks Carl, this worked for me too. What I don't understand is, I have the cert installed on the DC but didn't help.


SF Version 1912 LTSR



I realized that I had configured the DC without installing the SSL Cert. and binding it to the IIS at first. If you want the DC to work with HTTPS, install the SSL Cert. bind it to IIS and then configure your DC.


Correct me Carl if I am wrong.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...