Jump to content
Welcome to our new Citrix community!
  • 0

XA78 - Open multiple desktops - single icon


Question

Dear all,

 

I am sure I am missing something obvious, but how do you allow a user to open multiple sessions of the same published 2012r2 desktop in XA 7.8?

 

ie, by clicking on the same icon in Storefront twice  and getting two separate desktops?

 

I've read the threads about the "Maximum Desktops per user" option being taken away in 7.8, and the ability to give the user a 2nd desktop through the 'desktops' tab on the Delivery Group, but I don't want to give them a 2nd icon, just let them launch multiple sessions from the same icon (Which is how it works under XA65 & WI, even with workspace control enabled)

 

set-BrokerEntitlementPolicyRule "DeliveryGroupName" -SessionReconnection DisconnectedOnly doesn't seem to make any difference either.

 

 

Thanks!
Dave

 

 

 

 

Link to comment

8 answers to this question

Recommended Posts

  • 0

Ah, OK, thanks Carl, I never got round to ticking the box in 7.6 & .7.7, before upgrading to 7.8 and the box disappearing!

 

pc-dok, yes, I would like to have more than published desktop per user, but with only one icon.. I will test with workspace control disabled, but then again I like having that too... I guess cake and eat it was taken away with the new versions.

Link to comment
  • 0

I know this post is pretty old, but did you find a solution?

We have the same Problem with Xendesktop 7.15

 

- Set-BrokerEntitlementPolicyRule "DeliveryGroup" -SessionRecoonection DisconnectedOnly run on DG

- GPO RDS Setting "Restrict eah user to a single session" - Disabled

 

Doesn't work neither on Webinterface nor on SF

Webinterface Settings are the same as for the old XA 6.5 farm where it works perfectly.

Not matter if I disable or enable Workspace Control, makes no difference

 

Thanks

Link to comment
  • 0

I believe you need to use -SessionReconnection SameEndpointOnly if you want each signon to get a unique session.

 

I am actually having the same problem but with published Applications. This setting doesn't work for applications.

Link to comment
  • 0

I got this to work by doing the following:

Open Powershell ISE as admin on the Delivery Controller.

 

Copy and paste the following commands and execute:

 

$Current = Get-BrokerEntitlementPolicyRule
foreach ($name in $Current) {
Set-BrokerEntitlementPolicyRule -Name $name.Name -SessionReconnection DisconnectedOnly
}

 

Now you can launch multiple sessions of the published desktop

 

For Published applications you run:

$Current = Get-BrokerAppEntitlementPolicyRule
foreach ($name in $Current) {
Set-BrokerAppEntitlementPolicyRule -Name $name.Name -SessionReconnection DisconnectedOnly
}

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...