Jump to content
Welcome to our new Citrix community!
  • 0

Restore Citrix Environment


Nick Tugnao

Question

Hi

We have an existing Citrix infra setup on Xen-app 7.5.  Please see below for an overview of the existing setup.

 

We are planning to setup a test environment using the VM Images (snapshots) of the production servers.  (refer the attached document)

 

  • Performed a full backup of Xenapp and PVS database and restored to a new database using the same hostname 
  • Installed the PVS server using VM snapshot.
  • Launch the provisioning service console, configured new database details and we are able to view the site, servers, vDiskppol, Device Collection and stores.
  • Installed the Delivery Controller using the VM Snapshot, and when we launch the Citrix Studio, we are receiving the following error;

After I enter the Delivery Controller IP address, FQDN, Hostname, I receive an error

ServiceNotInSiteDB

 

We have tried the powershell command-line options and we are able to;

  • Reset the DB connections strings to $null, test DB Connection ((refer the attached document Fig-2)
  • Test DB connection (refer the attached document Fig-3)
  • Adding DB Connection String gives the following error: (refer the attached document Fig-4)

I have verified the user privileges and in the production setup, this user has full-admin privileges.

  • Verifying the service-status gives the following error; (refer the attached document-Fig-5)

Let me know if I am missing any step to reconfigure the Delivery Controller and the Database Server.

 

Best Regards,

MK

 

Link to comment

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...