Jump to content
Welcome to our new Citrix community!
  • 0

Machine catalog having errors with PVS servers


Tavarvess Ware

Question

Never seen this error before hope someone can assist.  "The virtual machine with mac address in the selected device collection could not be found on any available connection.

 

I have tried the following:

 

  1. Restarting all management servers (PVS, DDCs)
  2. Importing many PVS Streaming servers to just 1
  3. Connecting to different pvs machines during import

 

Any suggestion would be greatly appreciated never encountered this before.  I read that it is because of possible mismatch mac addresses but I verified that as well.

Link to comment

9 answers to this question

Recommended Posts

In your PVS console under Device Collections, all your target VMs should be listed as objects. Each entry there has a MAC address. Whenever a VM boots through the PVS servers, the VM must match one of the VM objects in the PVS view.

 

Most likely the VM you are trying to boot has had its MAC address changed. See if there is a corresponding object of it in PVS console and change the MAC, and if not, then create one.

Link to comment

 Thanks Kailas,

 

1.  I have tried multiple machine accounts

2.   I am trying to do it one at a time for simplicity of troubleshooting but I have tried that as well.

3. 

           a.  Catalog are you saying in PVS (I have tried that)?  

           b.  Create a new machine catalog (same error with the MAC Address)

 

I have verified that I have no duplicates and that the mac address matches the pvs mac.  Very weird as this is the first time this has happened.

Link to comment

I just ran into the error with Citrix XenApp&XenDesktop 7.17  /  PVS 7.18 / vCenter & ESXi 6.0.

 

In my case it was a Connection error to the Hypervisor

Quote

   Get-HypVMMacAddress : Cannot connect to the VCenter server due to a certificate error. Make sure that the appropriate certificates are installed on the VCenter server, and install the appropriate certificates on all machines that contain instances of the Host service.  

although test connection to Hypervisor displayed everything correctly...

Solution 3 works fine in my case:
https://support.citrix.com/article/CTX138640

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...