Jump to content
Welcome to our new Citrix community!

Receiver "Your apps are not available at this time..." Error


Gregor Blaj

Recommended Posts

Hi,

 

With the configuration below I am unable to get Receiver to display any published applications, showing the "Your apps are not available at this time..." error. Logging in via a browser works fine.

  • StoreFront: 3.5.0.23
  • NS VPX: NS11.0 65.31.nc
  • Receiver: 4.4.1000.16 (Tried 4.2 and 4.3 too, on multiple PCs)

StoreFront Configuration

Netscaler Configuration

AuthManLog.txt
 

Description: An unusual challenge reason 'gatewayclaimsinconsistent' was received from the server while accessing URL 'https://xenapp.domain.com/Citrix/Store1/resources/v2?clientName=PC1&clientAddress=<Client IP>'.

StoreFront Server Event Log

Gateway data from the request and the authentication token are not matching. Request was made to store Store1.
 

Request data:
  Remote Address: <Netscaler SNIP>
  X-Citrix-Via: xenapp.domain.com
  X-Citrix-Gateway:
  X-Forwarded-For: <Client IP>

Token data:
  Remote Address:
  X-Citrix-Via:
  X-Citrix-Gateway:
  X-Forwarded-For:

Gateway configuration:
System.String[]

 

Any help appreciated.

Link to comment
Share on other sites

Hi Carl,

 

I'm only testing internally, haven't configured NAT etc yet but can do if needed.

 

Looking at Receiver_.log it seems to report as 'inside', which is correct.

 

[2016-05-16 12:12:21:624] [9696] [V6Interfaces.cpp:124] CSDKLocationAwareness::GetNetworkLocationForStore, storeAddr https://xenapp.domain.com/Citrix/Authentication/auth/v1/token
[2016-05-16 12:12:21:624] [9696] [sRProvider.cpp:508] SRProvider::GetStoreFromURL full store address not found, looking for scheme-host-port, shpAddress is xenapp.domain.com
[2016-05-16 12:12:21:624] [9696] [NetworkLocation.cpp:311] intResults.size() = 1
[2016-05-16 12:12:21:624] [9696] [NetworkLocation.cpp:318] .....Beacons report: inside
[2016-05-16 12:12:21:624] [9696] [NetworkLocation.cpp:260] Location for store 2990025282 is INSIDE
[2016-05-16 12:12:21:624] [9696] [NetworkLocation.cpp:276] Location for url https://xenapp.domain.com/Citrix/Authentication/auth/v1/token is INSIDE
[2016-05-16 12:12:21:624] [9696] [V6Interfaces.cpp:130] CSDKLocationAwareness::GetNetworkLocationForStore, network state:1

 

EDIT:

 

Beacon configuration:

 

Internal Beacons: Use the service URL

External Beacons: http://ping.citrix.com, https://xenapp.domain.com

Link to comment
Share on other sites

  • 9 months later...

Sorry for the necro,

 

was this case ever solved? I am seeing the same issue in my test environment. 

 

Native receiver will log int with my username, but when I attempt  to access any resources, i get the same error as mentioned in this post.

 

thanks

 

I'm not sure what fixed the issue in the end but what do you see in the SF logs? Also, can your SF severs communicate with the XML ports on the Delivery Controllers (brokers)?

Link to comment
Share on other sites

  • 8 months later...
On 16/05/2016 at 2:18 PM, Carl Stalhood1709151912 said:

Is this problem happening internally, externally, or both?

 

What is the Internal Beacon?

I too have the same problem. My receiver works fine from internal network using Single SignOn. When accessing it from external using 2 factor auth, receiver for web works fine and receiver does not work. The authentication policies and session policies are different for Receiver as per the Vendor or expert recommendation. 

 

Has anyone found a solution? 

 

 Error: Could not Logon. There are no Apps available at this time.

Link to comment
Share on other sites

  • 2 years later...

I had the same problem and below is the fix I did.

 

SF URL:  https://connect.domain.com

Gateway URL:  https://gateway.domain.com

 

Internal beacon: Use the service URL

External beacons: https://gateway.domain.com & http://ping.citrix.com

 

Internal access was working fine through Web and WorkSpace App using both URL's.

External access was working only through Web using Gateway URL, SF URL was not published for external access.

 

Upon checking WorkSpace App local logs from external machine, I found the below;

 

image.thumb.png.f40b1270b3b3bd3ab5bf0cf9d382e5cb.png

 

I simply deleted the DNS record of  SF URL from the public DNS server and it worked with no issues.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...