Jump to content
Welcome to our new Citrix community!

Test Netscaler KVM Install

Recommended Posts

I'm having a bit of a problem installing a version of the Netscaler using KVM.


Granted, my knowledge of KVM is limited at best, but in this scenario I am trying to piggy as a virtual machine on a test box that runs Unraid (v. 6.1)


I've been fiddling with it enough to get it to boot, but there is still something wrong because it doesn't seem to actually launch the Netscaler part, just gets stuck in the FreeBSD boot process.  


The final lines that come on the screen show me the following:


Define disks configuration: (vtbd0) NO.DISKS

Enter full pathname of shell or RETURN for /bin/sh:

\u@                      {this is a command prompt}


From there I can run nsconfig, but it doesn't seem to record anything. When I set the NSIP for instance it can take me through that menu, but when it brings me back to the "main menu" it still shows "not set" for the NSIP or the subnet mask.  Hitting 7 to Apply changes gives the following


ERROR : Error(s) occurred - some or all changes may not be applied.  The configuration must be saved and the system rebooted for these settings to take effect.

Do you want to save the new configuration? [Yes]:  //I type yes

ERROR:  Connection failed

Do you want to reboot the system now? [No]:  //I type yes



From there it just dumps me back to the "\u@" command prompt


it seems to me that it must be a driver or hard drive issue, but for the life of me I cant figure it out.  My lack of knowledge about KVM is the problem here, but it would be useful to get this running on this test server so I'm looking for anyone that can shed any insight for me here.  any help would be appreciated.



Link to comment
Share on other sites

  • 4 weeks later...

Hey James,

i had a play around with this last night and im getting the same error.

i had a look at the xml file that comes with it and notice its passing through a normal IDE controller and by default Unraid passes a SCSI controller so im guessing this is the problem

ill have another look at it tonight and let you know if i get it working.

  • Like 1
Link to comment
Share on other sites

  • 1 month later...

Hi James,


I'm also trying to get a VPX stood up on my unRAID build at home, and have run into the same issue.


Taking Josh Elliot's advice, I started tinkering with the XML file and changed around the disk type and controller  portions in order to get the NS to boot and show the proper partitions.



<disk type='file' device='disk'>

      <driver name='qemu' type='raw'/>
      <source file='/mnt/user/KVM/vpx/NSVPX-KVM-11.0-66.11_nc.raw'/>
      <target dev='vda' bus='ide'/>
      <address type='drive' controller='0' bus='0' target='0' unit='0'/>
    <controller type='ide' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>




The issue I'm seeing now that the disk issue seems to be resolved is that I cannot see a NIC when booting, so I can't save any initial setup (and the PPE fails to start). I'm 100% not a KVM expert, but thought I'd pass along what I found in hopes that it might help out. If anyone is able to figure out what I might be missing as far as NIC not showing up in the VPX, please do share!

Link to comment
Share on other sites

  • 6 months later...

Have you guys tried using VirtIO drivers for both disk and nic?


I don't have an unRAID box but I just setup a VPX on my Ubuntu box and I'm using VirtIO for both disk and nic


    <disk type='file' device='disk'>
      <driver name='qemu' type='raw'/>
      <source file='/home/user/Templates/NSVPX-KVM-11.1-49.16_nc.raw'/>
      <target dev='vda' bus='virtio'/>
      <alias name='virtio-disk0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x0'/>
    <interface type='network'>
      <mac address='52:54:00:af:6c:f2'/>
      <source network='dmz123' bridge='virbr1'/>
      <target dev='vnet0'/>
      <model type='virtio'/>
      <alias name='net0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
Link to comment
Share on other sites

  • 4 years later...

i dont like old threads without a solution.. :-)


here you go:


Edit the XML and add after </devices> (between </devices> and </domain> )following:


  <qemu:arg value='-cpu'/>
  <qemu:arg value='Skylake-Client,kvm=on,vendor=GenuineIntel'/>


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...