Jump to content
Welcome to our new Citrix community!
  • 0

DNS Updates Fails On VDA


Network Operations

Question

I'm scratching my head against a weird issue.

 

Current Citrix setup:

 

XA 7.6 on Server 2012 R2

Provisioned via MCS.

IP Address via DHCP.

DNS AD Integrated, dynamic updates set to "Secure Only"

 

When newly provisioned via MCS, the VDA will register themselves in DNS, no issues.  But if for whatever reason the machines gets a new IP Address. lease expires, or the master image gets updated and I re-provisioned and the machines gets a new IP Address, DNS doesn't update.

 

I get Event ID: 8018

 

The system failed to register host (A or AAAA) resource records (RRs) for network adapter with settings:

 

                          Adapter Name: {xxxxxx-xxxxxxx-xxxx-xxxx-xxxxxx}

                  Hostname : ctxsrv01

                         

                          Primary Domain Suffix: domain.com

 

                          DNS Server List: xxx.xxx.xxx.xxx, xxx.xxx.xxx.xxx

         

                          Sent update to server: <?>

 

                          IP Adress(es) : xxx.xxx.xxx.xxx

 

The reason the system could not register these RRs was because DNS server contacted refused the update request.  The reason for this might be (a) you are not allowed to update the specified DNS domain name, or (b) because the DNS server authoritative for this name does not support the DNS dynamic update protocol.

 

To register the DNS host (A or AAAA) resource records using the specific DNS domain name and IP addresses for this adapter, contact your DNS serer or network systems administrator.

 

I've set DHCP reservations as work around, but I'd rather not have to do that.

 

Please help.

 

Thanks.

Link to comment

5 answers to this question

Recommended Posts

Hi,

 

I am also facing the same Issue, DHCP renewed the IPs today for all 20 HSD servers, These updated IPS are replicated in the DNS so nslookup still resolving the old IPs.

 

Still the desktops launches are working fine. Did you find any solution?

 

Infra:

VDA 7.6.300.7020 with mixture of 2012 R2 & 2008 R2 SP1

DHCP 2012 R2 server

ADDS / DNS  - 2012 r2 Server.

Link to comment

I have similar issue on my Windows 10 VDI (MCS) and Windows 2012 (PVS) Servers.  If ip address changes or vdi/server reboots, the dns goes missing.  On the client side, we see socket error 10049 trying to make a connection.  Per Citrix Support, I need to have a startup script that will run ipconfig /registerdns.  I am currently in the process of doing it but unfortunately the command requires admin priviledges, which I have not been able to work.

Link to comment
41 minutes ago, Michael Southwell said:

arafiqu862 do you have the link to the Citrix article or a copy of the instructions they have provided? We are getting the same issue in our environment and would like the steps to resolve this.

Fix # 1: https://support.citrix.com/article/CTX135250 < - I didn't do this.

Fix # 2: Try setting up a startup script via GPO to run ipconfig /registerdns. It didn't work for me, so I am looking into scheduled task to run upon system startup.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...