Jump to content
Welcome to our new Citrix community!
  • 0

Windows 10 VDI Nuances/Performance and Logon Passthrough Auth


Jeremy Stanley

Question

So I'm not sure if this is a configuration issue on my end, or the fact that this is the first Win10 supported VDA.

 

First, pass-through authentication doesn't appear to work for initial logon.

We are using Wyse Xenith thin-clients. I log in via the WyseOS, which then sends me to the Win10 logon screen where I have to enter credentials again.

With my Win7 VDI, the credentials are passed through so I only need to log in once.

 

Second, performance in Win10 seems to be... not that great. It's really choppy. Trying to move windows around and it's jerky movement. I even upped the VM to 4 vCPU and 8BG RAM with no change. I already tried giving it 32MB for video RAM. Back-end storage is Netapp, and it's running on an aggregate of 15K SAS drives. The pagefile is on an SSD aggregate.

Our Win7 VDI VM run fine with 2 vCPU and 4GB RAM.

 

This is a private VDI, as we are just testing it out, so I didn't run the optimization tool/import reg file. Though we did not run the tool for our Win7 VDI VMs either.

 

I've also found that the "Disconnect" option isn't available with the power options; only Shut Down and Restart. Though that may be a Win10 thing.

 

Out XenDesktop server farm is still running 5.6 FP1, whether or not that matters, but I am in the process of scheduling and prepping the upgrade to 7.6.

 

Anybody else experiencing, or find the resolution, for either of these issues?

I figure this belongs here, since it's related to the 7.6 FP3 VDA.

Link to comment

8 answers to this question

Recommended Posts

  • 0

Glad to see I'm not the only one.

Are your VMs also running with the "Citrix Display Only Adapter" instead of the WDDM driver? I tried manually selecting the "Citrix Display Driver (Citrix Systems - WDDM), but it errors out with "The driver selected for this device does not support this version of Windows."

 

I know Microsoft made some changes to the display driver model for Win10, so I'm guessing that's why. I'm also wondering if that may be part of the display performance issues.

Link to comment
  • 0

Hello,

we have the same problem, passthrough Authentification is not working with Windows 10. Did you find a solution to this problem? I am unable to track down the issue..

 

Performance on the other hand is very good. Working with my W10 VDI the whole day and no performance problems at all.

Dedicated VDI 8GB Memory 2 CPU Xendesktop 7.6  

2 Display adapters are listed: Citrix Display Only Adapter and VMware SVGA 3D.

Link to comment
  • 0

I'm the only one currently running it, so I haven't done too much more digging around. Since the passthrough authentication is a minor annoyance, I have bigger fish to fry.

 

What are you connecting with?
I notice jerkiness when dragging a window from 1 monitor to the other.

 

I don't think it could be an issue with the Wyse Xenith itself... only other thing I haven't tried yet is giving my VM more video memory; currently set at 32mb, but didn't make a difference from the original 8mb.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...