Jump to content
Welcome to our new Citrix community!
  • 0

Published Application launch error with event ID 1480


Praveenraj T

Question

Hi Folks, 

 

We have XA 7.6 delivery controllers and XA 7.5 VDA servers with UPM profile 5.1.  Users are accessing published application through Netscaler 9.2 and Web interface 5.4

 

Recently we have been receiving many user impacts across the locations, reporting that they are receiving the below error while accessing the published applications through citrix. 

 

Error Screen shot has been attached. 

 

 

"Application xxx failed to start.

 
The Citrix server is unable to process your request to start this published application.
Please try again. If the problem persists, contact your administrator."
 
 
Steps taken in order to provide a solution
1. Deleted the user profile on the servers locally - didn't help
2. Deleted the user profile on the servers locally and recreated the UPM profile- Initially worked for some time, later the issue recurred for the user
3. Detached network drive(s) from the user account and tested- didn't help
4. Verified group policies applied on all Citrix servers—no issues found
5. Verified Microsoft patches and Citrix-installed hot fixes on all servers—no issues found
6. Made registry modification on all VDA servers as per a Citrix article CTX132243-didn't help
7. No issues with Antivirus software installed on Citrix VDA servers
8.Upgraded to the latest version of VDA 7.6 on couple of Citrix VDA servers and tested - didn't help
 
 
Findings,
 
whenever user received the error while accessing application, we noticed that 1480 event id has been logged on the VDA servers
 
Event 1480 message for your reference. 
"Failed to launch application Remote Desktop Conn with command line 'C:\Windows\system32\mstsc.exe'.  Ensure that the application is installed and that the user has permission to launch it. "

 

Restarting the affected server helping the user to launch the application at least for one day and later issue reoccurs again for the same user and as well new user

 

We also noticed using process explorer that the impacted user the process WFSHELL.exe is terminating during the application launch. 

 

 

Would like to know if any one come across the same situation? any inputs to investigate further?

 

Thanks,

Praveen

 

post-10836365-0-97351000-1445533129_thumb.jpg

Link to comment

9 answers to this question

Recommended Posts

  • 0

We have same issue, unable to launch DSA.MSC, getting same error.

 

Failed to launch application command line '"mmc.exe C:\Windows\system32\dsa.msc"' on client' for domain/user 'XXXXXX-' in session '3'.   Ensure that the application is installed and that the user has permission to launch it.

 

Any help?

 

#Amar.

Link to comment
  • 0

What version of Citrix?

 

In your published app, the Path to executable should be c:\windows\system32\mmc.exe. Don't put anything after it.

 

The command line argument should be C:\Windows\system32\dsa.msc.

 

Note, if you're trying to run this as a non-administrator then it might not work if UAC is enabled.

  • Like 1
Link to comment
  • 0

Посмотрите системную переменную PATH. В начале списка может оказаться путь к файлам установленного ПО, имена которых случайным образом могут совпасть с именами системных файлов Citrix. Например, после установки ПО Infotmatica наблюдается такая ситуация. В частности при старте сессии должен запускаться системный файл CMSTART.EXE. Файл с аналогичным именем присутствует и в данном ПО. В результате вместо системного файла Citrix стартует файл из ПО Infotmatica и запуска сессии не происходит.  

Link to comment
  • 0

I have same issue but for few users. Other user can using very well . We have Xenapp 6.5 UPM profile setup. I also tried many steps mention above but still issue not resolve. For work around we created new domain id for user to login into citrix. If any one find the solution kindly comment also mail me "rajesh.korpe@toysrus.com"

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...