Jump to content
Welcome to our new Citrix community!
  • 0

Receiver 4.3 Desktop will not auto-reconnect when logging into a machine

Frank Mazzucco


We are in the process or testing Receiver v4.3.100 for rollout to our LAN based machines. Currently, we have v3.3 in production and when a user logs into their LOCAL machine, if they have a disconnected and/or active session it will automatically launch.


This feature is not working in Receiver v4.x (I have tried 4.2, 4.3, and 4.3.100). I also notice the following different behaviors in Receiver 4.x; (1)when logged into a local machine, hitting ‘Refresh’ from the Receiver reconnects all disconnected/active sessions AND (2)when logged into a local machine, launching a single session will also reconnect any other disconnected/active XenDesktop and/or XenApp sessions. After reading up on this further, I realize that this is by default.


I tried to resolve this by modifying the WSCReconnectMode entry in the HKLM\Wow6432Node\Citrix\Dazzle key. If I change it from the default value of ‘3’ to ‘8’ it fixes the Refresh issue and the issue where all sessions are reconnected if a single session is launched.


However, the Receiver will not reconnect sessions at Windows logon; I tried creating the same entry under the HKCU key, but it does not fix it either. Also worth noting is that when I select the value of ‘4’, which is supposed to reconnect sessions when the Receiver interface opens, that does not work either.


Something weird that I noticed is if I lock my machine, then unlock it, my sessions will reconnect.


Any advice would be greatly appreciated.



Link to comment

8 answers to this question

Recommended Posts

  • 0



I am having the exact same issue; will not reconnect a XenApp session when logging on to a computer, be that the same computer or a different one. However, like your situation, if the user locks and the unlocks the machine the session is reconnected. Very odd.


For the full picture:


Storefront 3.0

XenApp 6.5

Receiver 4.3.100

Windows 10 Ent


GPO specifying StoreFront account; and reconnect behaviour (Control when Receiver attempts to reconnect to existing sessions.): WinLogon, Refresh, Launch.


I can confirm if we Refresh Apps (Refresh), or open another application (WinLogon) the session is reconnected. However, if we open the Receiver either by double-clicking the Receiver Icon or right-click > open (Launch) the session is not reconnected.


For a work-around I have placed a shortcut in "shell:common startup" (C:\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp) that executes this command: "C:\Program Files (x86)\Citrix\ICA Client\SelfServicePlugin\SelfService.exe" -reconnectapps


Anyone found a solution to this?

Link to comment
  • 0

The engineer that I am working with at Citrix was able to reproduce the same issue in his lab. It took me two weeks, but I finally got an offline engineer to take the case, so I should be hearing back next week with a helpful update. I will post an update once I hear back from them.


Prior to the issue being reproduced I thought that is was an issue with my environment, most likely with the Receiver, but perhaps with the Store on the Storefront side. However, between you and the engineer having the same issue, I no longer think it is an issue with my environment. Also, for testing purposes, I created a test Store, but I had the same issue.


I also noticed the issue with WSCReconnectMode set to 4, sessions will not auto reconnect when the Receiver is launched. Actually, it appears that the only setting that IS working is the default setting of 3.


Environment details are as follows:

Windows 7 Professional (local machine where Receiver is running)

Receiver v4.3.100 (I also had the issue with v4.3)

XenDesktop 7.6 and XenApp 6.5 (neither of the two auto reconnect)

Shortcut-only mode (SelfService modei is disabled)

Storefront 2.6

Link to comment
  • 0

Not yet. The escalation engineer that I was working with last week is getting the Product engineering group involved.


Are you running in self-service mode or shortcut-only mode?

Have you tried creating a test Storefront store (one that is clean without any customizations) and pointing to that?


I have already tried both, but I am not ready to rule out Storefront yet. Citrix tested it also with the same results.

Link to comment
  • 0

Here is the final response that I received from Citrix as to what the issue is. I was told that it may be addressed in the next release of the Receiver:


The configuration of "Workspace control at logon" will take effect when receiver takes some additional operation to apply it, unfortunately such operation seems only triggered with some special UI that I don’t even see in current receiver deployment. Fortunately we can manually execute the command line(selfservices.exe -refreshConfig) to trigger the operation. 



Here is what I found in my final round of testing, before implementing the work around (the same one that was mentioned by doggates):


The testing was successful. When I place the following command in the Start Menu, the Desktop(s) launch at logon. Also, I disabled Workspace Control completely. Part of the problem with sessions not launching at logon, was that if you locked and unlocked your machine it WOULD launch disconnected sessions. So I pushed out an update via the Registry and set Workspace Control to 0(disabled).


I just put the following command in the Startup folder for All Users.

"C:\Program Files (x86)\Citrix\ICA Client\SelfServicePlugin\SelfService.exe" –reconnectapps


Also, I just wanted to revisit the testing that you and I performed last week. After we finished testing last week, I ran a few more rounds of tests. I was actually able to get it working pretty consistently using the method that you recommended. I created a GPO and included the following variables in it.


(1) Added the following entry in the ‘HKCU\Software\Microsoft\Windows\CurrentVersion\Run’ key.

Value Name: Self-service

Value Type: REG_SZ

Value Data: C:\Program Files (x86)\Citrix\ICA Client\SelfServicePlugin\SelfService.exe –logonreconnectapps


(2) Included the Store via the same policy


(3) Configured the ‘Control when Receiver attempts to reconnect to existing sessions’ to ‘WinLogon’.


When all of this was done, it seemed to be working OK. However, what I noticed was happening was when a user already had a Store configured in the HKCU(before the GPO was applied), the Store that got pushed down via Group Policy would populate in the HKCU key also, so the user would have two entries for the same Store. As a result, a disconnected desktop would launch (2) times, once for each Store configured in the registry.


Technically, the GPO would not get applied until after (1)the existing Receiver was uninstalled, (2) the Receiver Cleanup utility was run, and (3) the Citrix Receiver was reinstalled. This would mean that the HKCU hive should not have even had a Store in HKCU hive at the time GPO would have been applied, so it may have been a non-issue. However, I determined that the duplicate store issue would have opened up a whole new set of testing, and I did not want to go down that road, so I abandoned this method.


I just wanted to let you know that I was finally having some success with the method we used.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...