Jump to content
Welcome to our new Citrix community!
  • 0

CitrixReceiver.exe installation failed


Ian Burnell

Question

Trying to silent install receiver 4.1 with command line CitrixReceiver.exe /SILENT /includeSSON ENABLE_SSON="Yes"

 

During install box pops up saying installation failed. However if you click ok it completes successfully no problem. Looking at logs files it seems to be during USB component - this is the line from TrolleyExpress

 

14:08:51: Information - CInstallationManager::InstallComponent(694) - Component Install Commandline: REBOOT=ReallySuppress MSIDISABLERMRESTART=0 MSIRESTARTMANAGERCONTROL=0 ARPSYSTEMCOMPONENT=1 NEED_RECEIVER=n TROLLEYINSTALL=1 SILENT=1  ALLUSERS=1
14:31:56: Information - CComponent::CreateRegistryRecords(723) - Writing registry records for uninstall.
 

 

Notice the times on left of line it stopped at 14:08 and after I clicked ok at the failure pop-up happily continued at 14:31

 

I have tried version 14.1.200.13 and 14.2.0.10 and also tried different switch i.e citrixreceiver.exe /SILENT on its own - same issue

 

Given I need to deploy this to users via SCCM It must be a silent install so any thoughts appreciated

 

Link to comment

7 answers to this question

Recommended Posts

  • 0

Is there a current receiver or ica plugin on these systems? If so its best to uninstall the existing citrix client and then let the new citrix receiver install. I personally uninstall version 3.4, kill trolleyexpress.exe, then install receiver 4.2. I do this with a 3rd party installer, not SCCM but I would guess you can do the same sort of thing through its packager.

 

 

--Alan--

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...