Jump to content
Welcome to our new Citrix community!
  • 0

Screen resolution 1536x864 in Windows 10


Jacek Witkowski

Question

Hi,

 

I've upgraded to Windows 10 Pro x64 and now have a issue where when I connect to a remote machine using Citrix Receiver and a RDP session the resolution of the remote machine is 1536x864.

The remote machine is a Windows 2008 Standard x64 server (not R2).

 

My laptop has native resolution of 2048x1152 but is set to 1920x1080. I also have an external monitor also set to native 1920x1080.

  • I have adjusted the DPI settings on both screens to 100%.
  • I have changed the following executable's Compatibility settings to 'Disable display scaling on high DPI settings': wfica32.exe, wfcrun32.exe, CDViewer.exe, Receiver.exe (and any other exe in the Citrix folders).
  • I've also tried changing Windows 10 to use the old Windows 8.1 DPI functionality using http://windows10_dpi_blurry_fix.xpexplorer.com/. This helped with many other apps and Windows popups but not the Citrix issue.
  • I've tried Receiver 4.1, 4.2, 4.3
  • I've updated all video drivers (Intel and Nvidia)

Nothing has helped. I also ran up a Windows 7 Pro x32 Virtual Machine and remoted in using the VM with the same problems which seems really strange. Other computers not running Windows 10 don't have this issue.

 

Any ideas?

 

Thanks,

Jacek

Link to comment

7 answers to this question

Recommended Posts

  • 0

Weird problem. After more testing I actually have this issue with all Windows versions (7, 8.1).

I finally got in touch with our IT people and although I got the "nothing has changed" reply they did change the RPD screen size to 75% then 98% at their end as a fix. Didn't work. After much complaining they changed it to full screen/100% and guess what, it works again. Go figure.

Hence I have no real idea what they changed abut it was from the server side and to do with screen percentages if that helps anyone. 

Link to comment
  • 0

After changing properties of both files CDViewer.exe and WFICA32.exe, it worked like a charm... Thank you!

 

In my Windows 10 machine, Compatibility setting is little different. I had to follow below steps:

- Go to Compatibility tab in above two files (one after other)

- Check Disable fullscreen optimizations.

- Click Change high DPI settings

- Check "Use this setting to fix scalling problems for this program instead of the one in Settings"

- Check "Override high DPI scalling behavior."

- Click "Ok" and again click "Ok" to close the windows.

- Reconnect Citrix desktop and voila!

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...