Jump to content
Updated Privacy Statement
  • 0

MCS not refreshed at reboot


Question

Hi There,

 

We are using Citrix Machine Creation Services to provision multiple XenApp 7.6 machines.

I Thought that the machines should be in a clean state after a reboot.

 

I tried to reboot the machines from Citrix Studio, trough VMware Vcenter and in the VM itself but all changes on the XenApp server are retained after the reboot. Also tried a reboot schedule on the Delivery Group and fully shutdown the XenApp servers but still no luck.

 

Technical information:

Desktop Delivery Controller: 7.6.0.5026

Citrix Machine Creation Services: 7.6.1.5020 (Feature Pack 1)

VDA: 7.6.0.5026

OS: Windows Server 2012 R2 (including all critical updates)

Hypervisor: VMWare Vsphere 5.5.0, 2183111
(We use local storage on our cluster)

 

Hopefully someone can help me with this!

Is there a powershell command available to force a refresh?

Link to comment

Recommended Posts

  • 0

I found this script which made it easy to try and create everyting(catalogs) from Powershell.

http://stealthpuppy.com/xendesktop-mcs-machine-catalog-powershell/

 

When i do this, the catalogs gets created with CleanOnBoot True, and it works as it should.

I can still manage the Catalog from the GUI. Like creating more machines or updates the image, so the powershell is a 1 time thing pr. new Catalog.

I can live with that.

 

Mark, thanks for the hint with the CleanOnBoot attribute.

Link to comment
  • 0

You said that you are powering off the VM Master and then performed your snapshot to update your Machine Catalog.

 

I had this same issue where the Machine Catalog would not have any of the updates.

 

I had to create a snapshot of the Master VM while it was on.  Then after the snapshot was created i turned off the Master VM and updated the Machine catalog.  This update 3 of the 5 machines.  So i initiated one extra reboot from Studio to complete the pending update on the last two machines.  

 

Cheers. 

Link to comment
  • 0

In our case, when we ran "Get-BrokerHostingPowerAction -state Failure", we found that several "did not register in time".  Still trying to find out what caused that, but in the meantime, we added the "Pending Update" column to our Studio "Machines" view (click on "SEARCH" to list them all), and we did a "Force Restart" on all of them.  That made them pick up the new Image, Register properly, etc... 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...