Jump to content
Welcome to our new Citrix community!
  • 0

MCS not refreshed at reboot


Hi There,


We are using Citrix Machine Creation Services to provision multiple XenApp 7.6 machines.

I Thought that the machines should be in a clean state after a reboot.


I tried to reboot the machines from Citrix Studio, trough VMware Vcenter and in the VM itself but all changes on the XenApp server are retained after the reboot. Also tried a reboot schedule on the Delivery Group and fully shutdown the XenApp servers but still no luck.


Technical information:

Desktop Delivery Controller:

Citrix Machine Creation Services: (Feature Pack 1)


OS: Windows Server 2012 R2 (including all critical updates)

Hypervisor: VMWare Vsphere 5.5.0, 2183111
(We use local storage on our cluster)


Hopefully someone can help me with this!

Is there a powershell command available to force a refresh?

Link to comment

Recommended Posts

  • 1

If the machines are showing as "no" in the pending updates then the system doesn't think that there is anything to do. There are a few reasons why this may be the case the most likely being that the catalog update process didn't actually complete successfully and so there is nothing to associate with the machine. I think you'll need to do another catalog update and see if that works.



  • Like 1
Link to comment
  • 0

Im experiencing the same problem on XenApp 7.6 Server 2012 R2.

I have 3 Machine Catalogs. 1 that works (Resets on vm poweroff/on) and 2 that does not work.

All 3 says "Discard" in Persistent User Changes. 2 of the 3 catalogs is from the same master image snapshot.


I've noticed that in vSphere the working Catalog have checked the "Non-Persistent" flag, the 2 nonworking Catalogs has not. Maybe this is the reason?


Where can i debug futher?



Link to comment
  • 0

That is exactly the reason and I would suspect external interference has caused things to not be configured correctly.


When XenDesktop creates non-persistent machines on VMware it uses independent non-persistent disks on the VMs. If you have catalogs that don't have this set then they will not work as clean on boot machines.



Link to comment
  • 0

Just to clarify:

The working Machine Catalog has the following disk mode settings:

Disk 1 - Identity Disk - Independent Persistent

Disk 2 - Deltadisk (Linked clone from basedisk/masterimage) - Independent Nonpersistent


The NOT working Machine Catalog has the following disk mode settings:

Disk 1 - Identity Disk - Independent Persistent

Disk 2 - Deltadisk (Linked clone from basedisk/masterimage) - Independent mode checkmark is unchecked = Neither persistent nor nonpersistent 


I did not try to change the Independent mode. At least i cannot do it while the vm is running.

The MCS should already have done this though.

I'll try to create a new machine in the catalog and change the setting to nonpersistent while its shut down, and write back.

Link to comment
  • 0

I have now tried to manually set the independent mode to nonpersistent.

This does not fix the problem.

When i poweroff/on they do revert, but only to when i made the change. 

After i made the setting to nonpersistent, i tried to update the catalog.

I had 1 server powered off, and 1 powered on. 

I've told in the update process, that i should reboot the servers immediately.

The powered on server sure do rebooted, but it did not use the new basedisk. Neither did the powered off machine.

The workaround i have now is to delete the machines from the catalog, AD and Vmware, and to create new ones.

When i create new machines in the already updated catalog, the new machine uses the new basedisk.

Link to comment
  • 0



Can you give me a bit more information?


What type of machine are you creating, desktop or server?

What hotfixes and version do you have? Specifically do you have 7.6 HF2?





I'm creating Servers (Server 2012 R2)

The controllers are vanilla.

I applied 7.6 HF2 today though, to see if it made any changes. It did not.

I have yet to try and see if it works creating a new catalog.


Any tips?

Link to comment
  • 0

Sorry, I should have been clearer in the earlier email. Specifically HF2 has a bug which causes this behaviour and will need a new update.


Can you get the output from the following PowerShell command




Specifically the CleanOnBoot property.


The HF2 (and possibly earlier fix versions but not the 7.6 release version) of Studio have a bug and set the catalog to non-persistent and the ProvisioningScheme to persistent.



Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...