Jump to content
Welcome to our new Citrix community!

Netscaler hangs on ../cgi/setclient?wica

Recommended Posts

NSVPX 10.5 & Storefront 2.6


I've a number of articles on this and they all point to a communication problem between the netscaler and storefront.


I'v even redone all my settings using http://support.citrix.com/article/CTX139963 as a guide but it still hangs.


Are there any logs can look at to see where this is failing ?   I've tried to verify web connections using ping, traceroute, telent & openssl s_client -connect.  Ping and traceroute completed successfully.


telent and openssl both give http responses. storefront is configured for both http and https.


So I don't know where to look next.


Link to comment
Share on other sites

Seems like this is due to AG trying to use TLS 1.2 on NS 11.x to talk to StoreFront. To resolve in my environment, I setup a VIP for SF (even though I only had one server) and set the service/service group to disable TLS 1.1 and 1.2. I changed the session profile to use the VIP and all was OK. I found this out as there were TLS errors in the SF logs...


Hops this helps.

  • Like 1
Link to comment
Share on other sites

  • 3 years later...

I'll second the TLS Settings fix. Had used IISCrypto on the StoreFront servers (3.15) to lock it down to TLSv1.2 only. Even though the Virtual Server was configured to use 1.0, 1.1 & 1.2, it wouldn't connect. Relaxed the setting on the web server, and it worked. Unfortunately, the NetScaler is 10.5 (don't ask) and I'm trying not to break it. Fortunately, I'm replacing it as part of this project. :-)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...