Jump to content
Welcome to our new Citrix community!

File share bookmark, upload fails

Jani Kannisto

Recommended Posts


I have a problem with file share bookmark.

We just changed our MS dfs servers to Windows server 2012 (before win srv 2008).


Before any changes everything was working fine. Users could open enterprise file share bookmarks, download and upload files. After we changed our file server to win srv 2012 uploads are not working anymore. When pressing Upload it gives "Page cannot be displayed". Users still can open share and download files.


Citrix enviroment is still the same. We have changed firewall rules to new file server. Rules are same as before.


I took back old file server and it was good. I tried with another 2012 server and same problem with that.


Any ideas what's wrong with this?

Link to comment
Share on other sites

  • 4 months later...
  • 4 weeks later...
  • 3 weeks later...
  • 2 weeks later...
  • 2 months later...
  • 3 weeks later...
  • 1 month later...

Hi friends,

I have open ticket to Microsoft and solution is following :




As this caused by Citrix, because RFC’s not followed,  please request Citrix for update, or upgrade it  to newer version. We are glad to help you, providing necessary information.




Server 2008R2 is last server which will tolerate bufferoffset = 59,  and , because server version is still in extended support till 2018 you can use it instead of 2012R2.



PS: now I´m waiting for Citrix support :o) ..


  • Like 2
Link to comment
Share on other sites

  • 1 month later...
  • 4 weeks later...
  • 5 months later...

From the conversations I've had with Citrix they are aware of the issue and when I last discussed it with them (late last year) they didn't appear to have any intention of fixing it which is quite disappointing.


If more people were to raise this with Citrix it may rise further up the list of priorities but I wont be holding my breath

  • Like 1
Link to comment
Share on other sites

  • 5 months later...
  • 6 months later...

Hi guys,


We've had this issue lately that is creating a large issue for my company.


As currently none of the bookmarks will work with anything other than Dialect LM0.12 (NTLM v 1) and SMB1 (after all the network captures and Netscaler traces) and all our servers are currently upgraded to 2012R2 and above.


What methods has anyone else had to get this working either through Netscaler, or potentially even another product, as so far Citrix has not come to the party with a private hotfix to enable the use of SMB2.


Ondrej, unfortunately this is an issue that Citrix is 'behind the times' when it comes to the RFC and given that the published SMB1 protocol is mostly 25+ years old as published, I'd say its about time they at least moved into the post 2000 era by supporting SMB2. Even the product owner of File Services (SMB etc) at Microsoft said it is laughable that people are still using SMB1 given the glaringly obvious vulnerabilities.


There is multiple other solutions out there, but as a certified Engineer of Citrix I'd like to know they they have their customers interest at heart with regard to safety of their products and the feature-set they are selling.

Link to comment
Share on other sites

  • 2 years later...

Does anybody know if this has been fixed yet? We are running NetScaler 12.1 and using bookmarks to connect to file shares on a Windows 7 machine. This works just fine but we need to upgrade to windows 10. We did try that but as soon as we upgrade to windows 10 we can  no longer connect to the shares on that pc with bookmarks. It appears 12.1 is still using SMB1 to try and connect to the shares on the pc. Any help would be appreciated.




Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...