Jump to content
Welcome to our new Citrix community!
  • 0

Qfarm Server randomly in 2000


Luc Picarougne1709152666

Question

Hi all,

 

First of all I want to wish you an happy new year ! 

 

So I write this topic because we have a very strange issue on our xenapp farms (2 of them, not the same windows domain)

 

We had randomly some server in "20000 state" on our qfarm. It happens after the weekly reboot. 

The only way to resolve it for now is :

 

- restart the server again

- change the O.U of the server for having no more GPO, then put the server back in his original O.U

- change the licence servername on policy for all the farm's server

 

So we had the workarounfd but I still don't understand why we get this issue....

 

I noticed that the file located in :

C:\Program Files (x86)\Citrix\system32\cache

named 

MPS-WSXICA_MPS-WSXICA_MYSERVER.ini 

was not updated after the first reboot but will be updated if I reboot the server again...

 

All my parameters applied by policy can be retrieved in registry (servername, port, etc..) all the network flows are OK.

 

It's like the server can't updated the ini file.

 

Is it a way to understand why this file is not updated, and can we update it without reboot ? 

I tried everything (recreatelhc, gpupdate,restart ima...) with no success.

 

A case is open to support but whitout success for now.

 

thanks a lot for your help!

 

Rgds,

 

Luc

 

 

 

Link to comment

10 answers to this question

Recommended Posts

  • 0

Hi,

 

back in 2013, when me and my team were migrating from XA4.5/5/6 to XA6.5, we experienced the same issue on a large number of servers. We didn't find any solution so we postponed the upgrade for a few months. Meanwhile, we did some more tests, but couldn't make the issue to reoccur.

 

After we had migrated 70% of the XA farms (~200 servers) to XA6.5, the issue popped up again. It always happened after a reboot and only on servers with a higher latency (>50-100ms) to the datastore. At first it looked like, that the XA6.5 worker were not aware of it's license server (which in our case was distributed via IMA policy). So we deleted all policy settings (reg delete "hklm\software\policies\citrix" /f) on the affected workers and reapplied it via gpupdate. Which worked, but was a bit difficult to schedule, due to multiple reboots (we usually have 2 reboots with various actions running in between) and long startup times (the 'imaservice' service must be already in running state, 'start pending' would overwrite it again as soon as the state changes to 'running'). 

Further investigation and testing reveiled, that setting the start type of the 'imaservice' service from 'automatic' to 'automatic (delayed start)' finally solved our problem with the 'load 20000 issue'.

 

Since over 6 months since implementation, I didn't saw a single server with this issue again. Maybe worth a try.

 

 

Roland

  • Like 1
Link to comment
  • 0

I was able to resolve  my problem finally.

 

  1. Logged on to the XenApp server using an account with administrative access.
  2. Deleted all files and folders from the %PROGRAMDATA%\Citrix\GroupPolicy folder.
  3. Delete the following registry key: HKLM\Software\Policies\Citrix
  4. Ran the following at a command prompt: Gpupdate /force
  5. Restarted the server.
  6. Logged back to the XenApp server.

http://support.citrix.com/article/CTX130116

 

 

Azhar

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...