Jump to content
Welcome to our new Citrix community!
  • 0

SR_BACKEND_FAILURE_46 The VDI is not available

Daniele Renda1709154949


Hi guys,

on my Xen server 6.1 I'm trying to remove an old vdi that I'm not using in none VM.


So I tried first to remove the VDI of 300Gb:


xe vdi-destroy uuid=80b8d9af-705c-431e-b1cb-66a835de7479
Error parameters: , The VDI is not available [opterr=Command ['/usr/bin/vhd-util', 'query', '--debug', '-vsf', '-n', '/dev/VG_XenStorage-58d108cc-e9d9-fa6d-e55a-6f53fdd0b786/VHD-80b8d9af-705c-431e-b1cb-66a835de7479'] failed (22): error opening /dev/VG_XenStorage-58d108cc-e9d9-fa6d-e55a-6f53fdd0b786/VHD-80b8d9af-705c-431e-b1cb-66a835de7479: -22],


Then I tried to forget the vdi:

xe vdi-forget uuid=80b8d9af-705c-431e-b1cb-66a835de7479


and then rescan the storage:

xe sr-scan uuid=58d108cc-e9d9-fa6d-e55a-6f53fdd0b786
Error parameters: , The VDI is not available [opterr=Error scanning VDI 80b8d9af-705c-431e-b1cb-66a835de7479],

So now I have these 300Gb busy also if the vdi is not more present. How I can to definitly remove these disk?


Thanks so much!



Link to comment

12 answers to this question

Recommended Posts

I just made a test stopping all Vm and restard the physical machine but the problem persist.


To tell the thruth the vdi that now is not more listed (80b8d9af-705c-431e-b1cb-66a835de7479) is a disk that I want to delete. I'd like to remove all space allocation for this disk that now I don't see anymore in the XenCenter.


How I can solve this problem?



Link to comment

Thanks for the suggestion, I done


lvdisplay -v
    Finding all logical volumes



      --- Logical volume ---
  LV Name                /dev/VG_XenStorage-58d108cc-e9d9-fa6d-e55a-6f53fdd0b786/VHD-80b8d9af-705c-431e-b1cb-66a835de7479
  VG Name                VG_XenStorage-58d108cc-e9d9-fa6d-e55a-6f53fdd0b786
  LV UUID                WjZHQy-OrU3-1cUN-OSW3-LPs0-tE36-s7WWDt
  LV Write Access        read/write
  LV Status              NOT available
  LV Size                300.59 GB
  Current LE             76952
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto



 lvremove /dev/VG_XenStorage-58d108cc-e9d9-fa6d-e55a-6f53fdd0b786/VHD-80b8d9af-705c-431e-b1cb-66a835de7479
  Logical volume "VHD-80b8d9af-705c-431e-b1cb-66a835de7479" successfully removed

then I retried to rescan the SR:


xe sr-scan uuid=58d108cc-e9d9-fa6d-e55a-6f53fdd0b786
Error parameters: , The SR scan failed  [opterr=Command ['/usr/sbin/lvchange', '-ay', '/dev/VG_XenStorage-58d108cc-e9d9-fa6d-e55a-6f53fdd0b786/VHD-80b8d9af-705c-431e-b1cb-66a835de7479'] failed (5): One or more specified logical volume(s) not found.],


What is the problem now? Seems that Xen has the reference to VHD-80b8d9af-705c-431e-b1cb-66a835de7479 somehwere but I don't understand where!



Link to comment

Hope I can bring this one back to life.

I've been having a somewhat similar issue to the OP.


Server did a hard shutdown.  On reboot, one of the VMs wasn't running.  I detached two recently added disks, and the VM ran ok.

Looking at the SR, if I re-scanned, I got an error VDI not available.


I tried forgetting the VDIs etc and then re-scanning.  on the CLI, this gave SR_BACKEND_FAILURE_46


I followed the advice above to use lvdisplay , then lvremove.

No errors showing now, but if I do a rescan, I get nothing.  Are they gone?

If I start over, is there some way to stop it happening again?



Link to comment


This topic is now archived and is closed to further replies.

  • Create New...