Jump to content
Welcome to our new Citrix community!
  • 0

Citrix receiver for OS X 10.10


Swetha Balla

Question

Recommended Posts

  • 0

I use a smart card to connect to remote desktop to my work place. I get an invalid certificate error. When I downgraded back to Mavericks (10.9), it works fine. But on 10.10, I get the certificate error. I know that there is no issue with my smart card, as it has read the certificate (it's valid!), shows me the desktop login screen etc.

 

Does that help? Thanks! 

Link to comment
  • 0

I've noticed the same issue testing with Yosemite Developer Preview 7, Citrix Receiver for Mac 11.8.2.

 

Using safari, I can login fine to Storefront sites with 2 factor auth, or just AD authentication.  I haven't seen any issues using Safari.

 

Using the Receiver client though, sites with 2 factor authentication enabled don't work.  I get "cannot login to gateway, check your account settings and network connection".

 

Sites without 2 factor authentication work fine though with the receiver client.

 

Is a new session policy required on the Netscaler perhaps?

Link to comment
  • 0

After updating to the latest Yosemite beta I get this error message:

"You have not chosen to trust "Entrust.net Secure Server Certification Authority", the issuer of the server's security certificate."

 

I have of course chosen to trust the certificate from Entrust.net, and it worked fine on Yosemite before the latest update. Anyone have a solution to this?

Link to comment
  • 0

Hi,

 

I am using an Apple Macbook Pro (version? / os x 10.10.) with two 27" Samsung screens

and I currently have the following problem with the Citrix receiver (version?).

If I switch from the Citrix environment (expandet on both monitors) to the locale Mac environment and back

again, the screen falls back on only one monitor and can not be expanded again unless you restart the citrix receiver.

 

Please let me know wether there is a solution for the probelm or if there will be a new citrix version soon which solves these problems.

 

Thanks for your help.

Link to comment
  • 0

Hi,

 

I am using an Apple Macbook Pro (version? / os x 10.10.) with two 27" Samsung screens

and I currently have the following problem with the Citrix receiver (version?).

If I switch from the Citrix environment (expandet on both monitors) to the locale Mac environment and back

again, the screen falls back on only one monitor and can not be expanded again unless you restart the citrix receiver.

 

Please let me know wether there is a solution for the probelm or if there will be a new citrix version soon which solves these problems.

 

Thanks for your help.

 

 

  • Like 1
Link to comment
  • 0

I am having this same issue - updated to Yosemite (Mac OS 10.10) this morning. On 10.9.5, the receiver worked without an issue, and i could connect to my school's remote Windows environment. Now, since the upgrade, I cannot, and I get the error "Cannot log on to gateway" every time. I NEED this to work on school projects for my masters program (classes re start on Monday 10/20/14). Will this issue be resolved by that point? i see it has been hanging out there for over two months now unresolved. I am using receiver 10.8.2 .

  • Like 1
Link to comment
  • 0

My company is also experiencing this issue. Myself and another user confirmed the problem from our Macs after doing the OS X 10.10 upgrade. As a note, a work around for me seems to be to navigate to the address via Safari. The login is successful and resources are available on the page, after selecting an app or published desktop the resource launches utilizing the Receiver client.

Link to comment
  • 0

My company is also experiencing this issue. Myself and another user confirmed the problem from our Macs after doing the OS X 10.10 upgrade. As a note, a work around for me seems to be to navigate to the address via Safari. The login is successful and resources are available on the page, after selecting an app or published desktop the resource launches utilizing the Receiver client.

 

Exact same scenario here. Mac users aren't able to launch directly from the thick client, they have to use Receiver for Web. Not the end of the world, but still an unacceptable issue to have gone on this long for.

Link to comment
  • 0

After installing Receiver for Mac 11.9.0 Tech Preview the stuttering and slow response is gone.  Working ok but not perfect.  

 

While the stuttering that made it impossible to work in full screen Receiver is gone.  I'm noticing webpages in Chrome on my virtual desktop will display halfway.  Minimizing Chrome then maximizing seems to make it redraw and all the pixels finally show.

 

OS X 10.10

MBP 13" Late 2013 8GB

Virtual desktop = Win 8.1 

Storefront 2.6

NS Gateway 10.5 52.11

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...