Jump to content
Welcome to our new Citrix community!
  • 0

MCS & VMware ESX 5.5 - Delete Disk File Not Found




I'm not going to try and explain the error I'm seeing in my XenApp 7.5 environment that's using MCS to provision Server 2008 R2 VDA's - rather see the attached image.


There doesn't appear to be anything wrong with my environment at all, but the VMware administrator keeps pointing out these errors which are happening randomly.  There's some thought that the MCS process believes it hasn't cleaned it's provisioning process up correctly, but how could I check if there are pending tasks from this.


Would appreciate any thoughts that might lead to some solution (unless in fact it's expected, which the VMware administrator won't be happy with).





Link to comment

6 answers to this question

Recommended Posts

  • 0

OK - so I've found that the use of the "Get-ProvTask -Active $true" shows me the active jobs that are causing the error in VMware.  The VMDK files that they are referencing do not exist (as per the error) - so just wondering if there are any implications to doing a "Stop-ProvTask -TaskId TASKID" and "Remove-ProvTask - TaskId TASKID"?  I've seen the error in the test environment and run these commands, and all seemed OK.  But long term will this cause issues with MCS provisioning?

  • Like 2
Link to comment
  • 2

Hello I've faced this same problema with Xenapp 7.15, I deleted a datastore and a provtask active task was pending (i don't know why, I've faced many problems with that thing...)


Finally the solution was deleting a row in the database table and then the task is not regenerated anymore.


I followed this steps i found here: http://www.peters.com/preventing-correcting-image-cleanup-errors-citrix-machine-creation-services-mcs/

-Back up your database before making any changes.

-Open SQL Server Management Studio and expand your XenDesktop database. Right-click the table labeled “DesktopUpdateManagerSchema.PendingImageDeletes” and select “edit top 200 rows”.

-Remove any stale records.


Regards ;)

  • Like 2
Link to comment
  • 0

Hi Matt, 

I've a client who's experiencing the same issue from XD 7.5. 

We ran the same commands and it worked but when we tried to create another machines or catalogs we're getting these errors back again in VMware. 

Don't know if it has happened to you? Do you've any work around for this issue?


Link to comment
  • 0

Sorry to bump an old thread, but I'm also having this issue.  I was able to remove all of the provTasks listed.  However one task recreates itself with a new task id and the same non-existant vmware path.  Where do I need to look to fix this last issue?



Steve Hurd

Floyd Memorial Hospital

New Albany, IN

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...