Jump to content
Welcome to our new Citrix community!
  • 0

Receiver installation is corrupt, and I can't uninstall it!


SCOTT RIMES

Question

Hi Everyone,

 

I have a malfunctioning Citrix Receiver (v 4.1) on my laptop computer. When I click on hosted Apps the Receiver does not start and the Apps do not load.

 

I have attempted to uninstall the Receiver (both through the Control Panel, and a program called CCleaner), however I am met with the message below -

 

http://oi57.tinypic.com/2lu3rkx.jpg

 

I also have a copy of the log that was produced by the Receiver when I attempted the uninstallation -

 

https://dl.dropboxusercontent.com/u/89221088/TrolleyExpress-20140618-103713.log

 

Finally it has occurred to me that running the Receiver Cleanup Utility may help, is this advisable?

 

http://support.citrix.com/article/CTX137494

 

Any help here will be greatly appreciated. A prompt response would be very helpful as I will be travelling soon, and really need the Receiver working whilst doing so.

 

Kind Regards,

 

David

Link to comment

9 answers to this question

Recommended Posts

  • 0

Hi Oliver,

 

Firstly I recommend installing CCleaner (http://www.piriform.com/ccleaner/download/standard), a great little utility program that can (and has from my experience) remove programs that are stuck.

 

If the Receiver does not show up in the standard Control Panel 'Add / Remove' programs, then there is a chance that you will be able to uninstall it through CCleaner.

 

Let us know how you go.

 

Kind Regards,

 

David

Link to comment
  • 0

Hi Scott,

 

thanks for the advise. Uninstalling the corrupt Program is no more a problem for me. The reciever shows up in the 'Add / Remove' List but I couldnt uninstall it this way. Getting Errors. Microsoft FixIt Tool and the Receiver CleanUp tool can uninstall the Receiver.

But this is just the first step. How do I get a working installation? When I reinstall the Receiver I am getting the same issues again.

 

I've installed the Receiver on many Windows 7 clients -> No Problems here.

Then I had 2 XP Professional 32 Bit Clients -> No Problems.

On the third and fourth XP Professional 32 Bit Client I have these issues.

On all Clients was a previous installation of the Citrix OnlinePlugin. (We are switching from Xenapp 5 to Xenapp 7.5)

Are there any Requirements to the Receiver?  Java, Flashplayer, A special Windows Update / Service Pack, .NetFramework ?

Maybe someone of them cause the problem?  

 

Please I need to fix this till next Week.

Link to comment
  • 0

Hey I found out what causes the Problem. Its .Net Framework 4!

After uninstalling .Net Framework4 on my Test Client its working fine with .NetFramework 3.

 

But I need .Net Framework 4 on my CLients for some Industry Applications. So this is no solution for me but should help to localize the problem.

 

Is there a way to fix this?

Link to comment
  • 0

Hi Oliver,

 

Great to hear that you are making some progress; perhaps try to specify which .NET version the Citrix Receiver should use. I haven't done this, but believe that you sould be able to specify the desired .NET framework through the 'ConfigurationWizard.exe.config' file which is located in 'C:\Program Files\Citrix\Receiver'.

 

I got this idea from another forum, http://stackoverflow.com/questions/2046089/force-an-application-to-run-under-specific-net-runtime-version, please let me know if this approach works.

 

Kind Regards,

 

David

 

P.S.: Scott is my boss, and I am logged in using his account!

Link to comment
  • 0

Hey,

 

my last Post was not 100% Correct. You need .NetFramework 3.5 SP1 on your Computer. I had only 2,3 and 4 but no 3.5 on these Systems. After Uninstalling version 4 I had no Errors after the Installation and it was possible to uninstall the Receiver through the Windows Uninstaller but I couldnt start the Receiver. Then I installed 3.5 and it worked fine on my Test Computer.

 

On the Other Computer I did the same and it seems to work ( I Had no Errors and the 'Add Account' Windows appears) but I cannot add an account. Error: Your account cannot be added using this server address

The Server Adress is 100% correct. I did this on 50 Clients before :p

 

Any Ideas? I think I will open a new thread for this.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...