Jump to content
Welcome to our new Citrix community!
  • 0

Session printers disappear


Peter Ruxton

Question

This is only happening with Session printers which can disappear after a while. We have no other issues with users printing using desktops or laptops that use session printers  (if you read the update that isn't the case as it happend to me today using my home laptop)

 

Using XenApp 6.5 Windows 2008 R2 SP1 with 4 Controllers.

 

60 XenApp 6.5 Application session host mode servers

4 Web Interface servers all running  Web Interface 5.4

Using PVS Version: 6.1.18.1236 so all the servers are identical and use cache on device hard drive persisted (NT 6.1 and later)

4 STA’s

All patched with HOT FIX XA650W2K8R2X64R03 

 

36 Core servers in the Farm which deliver core apps like Office 2007, Internet Explorer etc

 

Print server is Windows 2008 R2 SP1 and same location as Citrix servers with the exact same print drivers

 

I thought it maybe because the users had gone to lunch and comeback after an hour and their printers had disappeared but it looks like that it does happen when users are still using their Thin client. Most of the users are on remote sites i.e abroad so I thought it could have something to do with the network links but I’ve tested on a same type of device where the citrix servers and print server are located using one of the users accounts.

 

For example if I open up notepad I see the session printers appearing and can print etc....If I leave the Wyse device for say 40 mins or so they can disappear but not all the time. If you then open up say another app i.e word they will re-appear.

Wyse Device HP-T-610 Win 7 embedded

 

 Users access their applications through web interface....The device isn’t on the domain but connected to the network. The devices are locked down so when they switch them on it has a URL within start up which opens up the web interface and allows the users to login and see their published apps. No printers are installed on the devices hence why we use session printers.

Farm policy is set up to use Citrix Universal Printer 6.2.7500.0 windows x64 in islolated mode for everyone. However for users who use Wyse devices or in house apps which need to use session printers we have printer policies setup for eah location i.e Hong kong, Spain etc and Ad groups assigned to them.

 

Obviously with session printers use can’t use Citrix Universal Printer. So using HP Universal Printing PCL 5 61.155.1.16448 windows x64 in isolated mode.The print server is located on the same site as the citrix servers and have the exact same drivers and setup in isolated mode.

 

I’ve Used StressPrinters_v1_3_2 software to see if the spooler would crash but seems fine.

 

You’ll notice I ran it against a LPT1 port but have run it against the location of the print server also.

 

Launching cmd.exe /C addprinter64.exe -name "HP Universal Printing PCL 5" -port "LPT1:" -driver "HP Universal Printing PCL 5" -proc "Winprint" -conc 5 -iter 5 -delay 0 -verbose

CMD process has been created. PID: ab4 (2740)

AddPrinter.exe process for "HP Universal Printing PCL 5" has been finished

 

--- Begin Log for "HP Universal Printing PCL 5" ---

AddPrinter Ver 2.01 © Citrix 2006-2007 (pid: 6236)

WARNING: thread id 0x1a24 may be stuck on AddPrinter for printer HP Universal Printing PCL 51!

WARNING: thread id 0x1e60 may be stuck on AddPrinter for printer HP Universal Printing PCL 52!

WARNING: thread id 0x1118 may be stuck on AddPrinter for printer HP Universal Printing PCL 53!

WARNING: thread id 0xbc4 may be stuck on AddPrinter for printer HP Universal Printing PCL 54!

WARNING: thread id 0x1790 may be stuck on AddPrinter for printer HP Universal Printing PCL 55!

WARNING: thread id 0xbc4 may be stuck on AddPrinter for printer HP Universal Printing PCL 54!

WARNING: thread id 0x1118 may be stuck on AddPrinter for printer HP Universal Printing PCL 53!

WARNING: thread id 0x1e60 may be stuck on AddPrinter for printer HP Universal Printing PCL 52!

WARNING: thread id 0x1790 may be stuck on AddPrinter for printer HP Universal Printing PCL 55!

WARNING: thread id 0x1118 may be stuck on AddPrinter for printer HP Universal Printing PCL 53!

WARNING: thread id 0x1a24 may be stuck on AddPrinter for printer HP Universal Printing PCL 51!

WARNING: thread id 0xbc4 may be stuck on AddPrinter for printer HP Universal Printing PCL 54!

WARNING: thread id 0x1e60 may be stuck on AddPrinter for printer HP Universal Printing PCL 52!

WARNING: thread id 0x1790 may be stuck on AddPrinter for printer HP Universal Printing PCL 55!

WARNING: thread id 0x1e60 may be stuck on AddPrinter for printer HP Universal Printing PCL 52!

WARNING: thread id 0x1a24 may be stuck on AddPrinter for printer HP Universal Printing PCL 51!

WARNING: thread id 0x1118 may be stuck on AddPrinter for printer HP Universal Printing PCL 53!

WARNING: thread id 0xbc4 may be stuck on AddPrinter for printer HP Universal Printing PCL 54!

Time elapsed: 109 seconds. Done with 0 errors.

--- End Log for "HP Universal Printing PCL 5" ---

 

Can some explain if the below is an issue as the print spooler seems fine and the Cpu or memory doesn’t spike. I do know when I run the same test against Citrix Universal Printer it does only take 5 seconds rather than 109 seconds

 

WARNING: thread id 0x1a24 may be stuck on AddPrinter for printer HP Universal Printing PCL 51

 

I know you’ll say look at using the Universal Print Server 1.0 which I am within Dev but can’t seem to get it working at the moment even though I’ve installed all the hot fixes and followed the white papers ref GPO’s etc Howver I really want to try nail the above first.

 

Hotfix UpsClient100WX64100 - For Universal Print Client 1.0 - English  

CTX136002 , created 12-Dec-2013

 

Hotfix UpsServer100WX64100 - For Universal Print Server 1.0 - English

CTX135891 , created 12-Dec-2013

 

 

I do have another question can you use the version which comes with XenDesktop 7 on Xenapp 6.5?

 

Update

 

I'm working form home today using my own pc and have connected to my citrix apps using the web inferface and added myself to one of the citrix session policies for one of our remote sites...I decided to publish Outlook and Notepad on one citrix server which I'm the only one with a connection to make sure it was working fine....I've been working fine and checking everywhere so often that I can still see the session printers with notepad, outlook and opening up attachments within outlook i.e Excel...Word etc and all seemed fine...

 

I have now just gone into a excel attachment and I can't see any of the session printers when I try print but I saw them prevouisly.....So I checked notepad and it was working fine and could see printers...The I opened up a new email and went to print and I could see the printers....Then I opened up an word doc attachment and could see the printers...

 

I've since gone back into the excel attachment and another excel attachment and still can't see the session printers...

 

I have since closed down outlook then tried opening it again and couldn't see any printers so I opened up notepad again and could see the printers followed by iopening up outlook again and can see the printers in both Outlook, Wor and Excel attachments.....

 

I really haven't got a clue what to do next so Pretty Pleassecan someone give me some idea's :-)

 

Theses are the errors can see on the Xenapp server which I'm connected to and I do see this one message quite often within our farm An error occurred when processing incoming CGP downstream data and The Software Protection service entered the stopped state.

 

 

Log Name:      Application
Source:        MetaFrameEvents
Date:          19/02/2014 13:43:54
Event ID:      1104
Task Category: (2)
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      xxxxxxx
Description:
Client printer auto-creation failed.  The printer driver is not allowed based on the Driver Mapping List policy.  Check your Driver Mapping List policy in the Citrix Policy Manager. Client name: (HOME-PC) Printer: (Microsoft XPS Document Writer (from HOME-PC) in session 2) Printer driver: (MICROSOFT XPS DOCUMENT WRITER)

Log Name:      Application
Source:        Reliability Server
Date:          19/02/2014 13:46:42
Event ID:      103
Task Category: (3)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      xxxxxxxxxx
Description:
An error occurred when processing incoming CGP downstream data.

 

Log Name:      Application
Source:        Application Virtualization Client
Date:          19/02/2014 13:38:29
Event ID:      3219
Task Category: (3)
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      xxxxxx
Description:
{tid=1398}
Failed unregistering callback tracking connected process termination (error: 997).

Log Name:      Application
Source:        Microsoft-Windows-User Profiles Service
Date:          19/02/2014 13:38:30
Event ID:      1530
Task Category: None
Level:         Warning
Keywords:     
User:          SYSTEM
Computer:      xxxxxxx
Description:
Windows detected your registry file is still in use by other applications or services. The file will be unloaded now. The applications or services that hold your registry file may not function properly afterwards. 

 DETAIL -
 0 user registry handles leaked from \Registry\User\S-1-5-21-3993207555-1388484385-4012490218-107937:

 

Log Name:      System
Source:        Service Control Manager
Date:          19/02/2014 14:41:46
Event ID:      7036
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      xxxxxxx
Description:
The Software Protection service entered the stopped state.

 

Log Name:      System
Source:        Service Control Manager
Date:          19/02/2014 14:46:48
Event ID:      7036
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:     xxxxxxxx
Description:
The Software Protection service entered the running state.

 

 

I have even made sure that this server has all the latest Microsoft security hot fixes but I must admit it doesn't have the latest office ones but I can't that being an issue.

 

 

 

 

 

 

 

Link to comment

2 answers to this question

Recommended Posts

  • 0

It looks like it only happens with Microsoft Office as when I open up Notepad and Inter explorer etc they keep the settings.....I've even only added one session printer and I can see session sharing its working as they are using the same seesion ID...I jhave made sure the Xenapp server now has all the latest patches for Microsoft office 2007.

 

Just thinking out loud but if it wasa driver issue then I wouldn't be able to see the session printer in Notepad,Internet Explorer Adobe etc...

Link to comment
  • 0
On 2/19/2014 at 1:24 PM, Peter Ruxton said:

This is only happening with Session printers which can disappear after a while. We have no other issues with users printing using desktops or laptops that use session printers  (if you read the update that isn't the case as it happend to me today using my home laptop)

 

Using XenApp 6.5 Windows 2008 R2 SP1 with 4 Controllers.

 

60 XenApp 6.5 Application session host mode servers

4 Web Interface servers all running  Web Interface 5.4

Using PVS Version: 6.1.18.1236 so all the servers are identical and use cache on device hard drive persisted (NT 6.1 and later)

4 STA’s

All patched with HOT FIX XA650W2K8R2X64R03 

 

36 Core servers in the Farm which deliver core apps like Office 2007, Internet Explorer etc

 

Print server is Windows 2008 R2 SP1 and same location as Citrix servers with the exact same print drivers

 

I thought it maybe because the users had gone to lunch and comeback after an hour and their printers had disappeared but it looks like that it does happen when users are still using their Thin client. Most of the users are on remote sites i.e abroad so I thought it could have something to do with the network links but I’ve tested on a same type of device where the citrix servers and print server are located using one of the users accounts.

 

For example if I open up notepad I see the session printers appearing and can print etc....If I leave the Wyse device for say 40 mins or so they can disappear but not all the time. If you then open up say another app i.e word they will re-appear.

Wyse Device HP-T-610 Win 7 embedded

 

 Users access their applications through web interface....The device isn’t on the domain but connected to the network. The devices are locked down so when they switch them on it has a URL within start up which opens up the web interface and allows the users to login and see their published apps. No printers are installed on the devices hence why we use session printers.

Farm policy is set up to use Citrix Universal Printer 6.2.7500.0 windows x64 in islolated mode for everyone. However for users who use Wyse devices or in house apps which need to use session printers we have printer policies setup for eah location i.e Hong kong, Spain etc and Ad groups assigned to them.

 

Obviously with session printers use can’t use Citrix Universal Printer. So using HP Universal Printing PCL 5 61.155.1.16448 windows x64 in isolated mode.The print server is located on the same site as the citrix servers and have the exact same drivers and setup in isolated mode.

 

I’ve Used StressPrinters_v1_3_2 software to see if the spooler would crash but seems fine.

 

You’ll notice I ran it against a LPT1 port but have run it against the location of the print server also.

 

Launching cmd.exe /C addprinter64.exe -name "HP Universal Printing PCL 5" -port "LPT1:" -driver "HP Universal Printing PCL 5" -proc "Winprint" -conc 5 -iter 5 -delay 0 -verbose

CMD process has been created. PID: ab4 (2740)

AddPrinter.exe process for "HP Universal Printing PCL 5" has been finished

 

--- Begin Log for "HP Universal Printing PCL 5" ---

AddPrinter Ver 2.01 © Citrix 2006-2007 (pid: 6236)

WARNING: thread id 0x1a24 may be stuck on AddPrinter for printer HP Universal Printing PCL 51!

WARNING: thread id 0x1e60 may be stuck on AddPrinter for printer HP Universal Printing PCL 52!

WARNING: thread id 0x1118 may be stuck on AddPrinter for printer HP Universal Printing PCL 53!

WARNING: thread id 0xbc4 may be stuck on AddPrinter for printer HP Universal Printing PCL 54!

WARNING: thread id 0x1790 may be stuck on AddPrinter for printer HP Universal Printing PCL 55!

WARNING: thread id 0xbc4 may be stuck on AddPrinter for printer HP Universal Printing PCL 54!

WARNING: thread id 0x1118 may be stuck on AddPrinter for printer HP Universal Printing PCL 53!

WARNING: thread id 0x1e60 may be stuck on AddPrinter for printer HP Universal Printing PCL 52!

WARNING: thread id 0x1790 may be stuck on AddPrinter for printer HP Universal Printing PCL 55!

WARNING: thread id 0x1118 may be stuck on AddPrinter for printer HP Universal Printing PCL 53!

WARNING: thread id 0x1a24 may be stuck on AddPrinter for printer HP Universal Printing PCL 51!

WARNING: thread id 0xbc4 may be stuck on AddPrinter for printer HP Universal Printing PCL 54!

WARNING: thread id 0x1e60 may be stuck on AddPrinter for printer HP Universal Printing PCL 52!

WARNING: thread id 0x1790 may be stuck on AddPrinter for printer HP Universal Printing PCL 55!

WARNING: thread id 0x1e60 may be stuck on AddPrinter for printer HP Universal Printing PCL 52!

WARNING: thread id 0x1a24 may be stuck on AddPrinter for printer HP Universal Printing PCL 51!

WARNING: thread id 0x1118 may be stuck on AddPrinter for printer HP Universal Printing PCL 53!

WARNING: thread id 0xbc4 may be stuck on AddPrinter for printer HP Universal Printing PCL 54!

Time elapsed: 109 seconds. Done with 0 errors.

--- End Log for "HP Universal Printing PCL 5" ---

 

Can some explain if the below is an issue as the print spooler seems fine and the Cpu or memory doesn’t spike. I do know when I run the same test against Citrix Universal Printer it does only take 5 seconds rather than 109 seconds

 

WARNING: thread id 0x1a24 may be stuck on AddPrinter for printer HP Universal Printing PCL 51

 

I know you’ll say look at using the Universal Print Server 1.0 which I am within Dev but can’t seem to get it working at the moment even though I’ve installed all the hot fixes and followed the white papers ref GPO’s etc Howver I really want to try nail the above first.

 

Hotfix UpsClient100WX64100 - For Universal Print Client 1.0 - English  

CTX136002 , created 12-Dec-2013

 

Hotfix UpsServer100WX64100 - For Universal Print Server 1.0 - English

CTX135891 , created 12-Dec-2013

 

 

I do have another question can you use the version which comes with XenDesktop 7 on Xenapp 6.5?

 

Update

 

I'm working form home today using my own pc and have connected to my citrix apps using the web inferface and added myself to one of the citrix session policies for one of our remote sites...I decided to publish Outlook and Notepad on one citrix server which I'm the only one with a connection to make sure it was working fine....I've been working fine and checking everywhere so often that I can still see the session printers with notepad, outlook and opening up attachments within outlook i.e Excel...Word etc and all seemed fine...

 

I have now just gone into a excel attachment and I can't see any of the session printers when I try print but I saw them prevouisly.....So I checked notepad and it was working fine and could see printers...The I opened up a new email and went to print and I could see the printers....Then I opened up an word doc attachment and could see the printers...

 

I've since gone back into the excel attachment and another excel attachment and still can't see the session printers...

 

I have since closed down outlook then tried opening it again and couldn't see any printers so I opened up notepad again and could see the printers followed by iopening up outlook again and can see the printers in both Outlook, Wor and Excel attachments.....

 

I really haven't got a clue what to do next so Pretty Pleassecan someone give me some idea's :-)

 

Theses are the errors can see on the Xenapp server which I'm connected to and I do see this one message quite often within our farm An error occurred when processing incoming CGP downstream data and The Software Protection service entered the stopped state.

 

 

Log Name:      Application
Source:        MetaFrameEvents
Date:          19/02/2014 13:43:54
Event ID:      1104
Task Category: (2)
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      xxxxxxx
Description:
Client printer auto-creation failed.  The printer driver is not allowed based on the Driver Mapping List policy.  Check your Driver Mapping List policy in the Citrix Policy Manager. Client name: (HOME-PC) Printer: (Microsoft XPS Document Writer (from HOME-PC) in session 2) Printer driver: (MICROSOFT XPS DOCUMENT WRITER)

Log Name:      Application
Source:        Reliability Server
Date:          19/02/2014 13:46:42
Event ID:      103
Task Category: (3)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      xxxxxxxxxx
Description:
An error occurred when processing incoming CGP downstream data.

 

Log Name:      Application
Source:        Application Virtualization Client
Date:          19/02/2014 13:38:29
Event ID:      3219
Task Category: (3)
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      xxxxxx
Description:
{tid=1398}
Failed unregistering callback tracking connected process termination (error: 997).

Log Name:      Application
Source:        Microsoft-Windows-User Profiles Service
Date:          19/02/2014 13:38:30
Event ID:      1530
Task Category: None
Level:         Warning
Keywords:     
User:          SYSTEM
Computer:      xxxxxxx
Description:
Windows detected your registry file is still in use by other applications or services. The file will be unloaded now. The applications or services that hold your registry file may not function properly afterwards. 

 DETAIL -
 0 user registry handles leaked from \Registry\User\S-1-5-21-3993207555-1388484385-4012490218-107937:

 

Log Name:      System
Source:        Service Control Manager
Date:          19/02/2014 14:41:46
Event ID:      7036
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      xxxxxxx
Description:
The Software Protection service entered the stopped state.

 

Log Name:      System
Source:        Service Control Manager
Date:          19/02/2014 14:46:48
Event ID:      7036
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:     xxxxxxxx
Description:
The Software Protection service entered the running state.

 

 

I have even made sure that this server has all the latest Microsoft security hot fixes but I must admit it doesn't have the latest office ones but I can't that being an issue.

 

 

 

 

 

 

 

we have the same issue, and we are trying to reach Citrix support ... yet we ended up at redirection loop. so no support and no solution for the issue since 2014!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...