Jump to content
Welcome to our new Citrix community!
  • 0

Screen refresh stops working

Fabian Meinzer



I've set up a Shared Desktop Server Farm and currently test it. But the ICA keeps "freezing". Especially when I scroll in gridviews of our ERP.
Its like the connection died, but it still receives inputs. I can still klick and type, but I cant see it. The Activity Manager shows that there are new processes.
Not even reconnecting to the Session fixes this. The Screen stays black.
This happens in default "medium" quality ICA setting

When I set the ICA Quality to High, it does happen too, but I can get the picture back by switching between window and fullscreen.

Anyone else has this ?

Running on VMWare ESX 5.1
Server 2008 R2 with latest patches


Edited by: NCVGMBH on 29.08.2013 10:40

Link to comment
  • Answers 65
  • Created
  • Last Reply

Top Posters For This Question

Recommended Posts

  • 1

We see the exact same issue. With quality settings set to "Build to lossless" it happens more often than quality settings set to "High". When this happens, the session stays in a connected state even when the session is closed. A user cannot reconnect anymore. After killing "ctxgfx.Exe", the user can reconnect again.


Anyone got a solution to this?

  • Like 1
Link to comment
  • 0


I saw you are having the same problem posted in the forum. We believe we are seeing the same issue with Cisco CAD. Works fine under rdp, but under ica we get random freezes and resizing or disconnecting reconnecting resets it to work again. I'm going to open a ticket with Citrix today to try to accelerate the solution. Could you tell me what you're SR number is so I can refer to it.

Link to comment
  • 0

Looks like wscott244 found a temporary solution!

I tested it in my environment and so far it seems to resolve the issue. It isn't a permanent fix so I will continue to work with Citrix and update the forums on their responses.

Work around:

To enable Adaptive Display First generation

• disable Desktop Composition redirection
• Enable legacy graphics mode

Thanks wscott244!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...