Jump to content
Welcome to our new Citrix community!
  • 0

The scan did not find any new vdisks


Benjamin Ross

Question

After the most recent around of Microsoft patching I've yet been able to add new vdisks to our pool. I've tried on all four of our servers (two different sites, each balanced for that site). I can update existing, delete, manage locks, and generally maintain anything that already exists but I cannot add new.

We're running Server 2008 R2 SP1 with SCEP 2012/VMM2012
PVS version 6.1.0.1088

I've tried with a PVP file, without to make it create a new file. Multiple images just in case there was corruption in the VHD. I've restarted the servers, checked to make sure it's not in offline mode, restarted SOAP and provisioning without any luck. I cannot add from any store.

Link to comment

4 answers to this question

Recommended Posts

  • 1

A colleague helped me resolve the issue.  I renamed the VHD but left the version number in the name so it was Win7BaseNew.23.vhd.  Because I left the version number, PVS thought that it was a version and didn’t have any record of it in the manifest file therefore couldn’t import it.  After renaming it to Win7Base60GB.vhd it imported fine.

 

The little things sometimes throw you for a loop J

  • Like 1
Link to comment
  • 0

I am having this same issue.  I have PVS 6.1 running on Windows 2008 R2 servers.  My Win7 image was out of diskspace so I followed this article http://virtexperience.com/2013/06/13/fastest-way-to-resize-a-pvs-vhd-file-using-diskpart/  however I can not import the vdisk that has been resized.  I am getting the error "The scan does not find any new vdisks".

 

This is what has been tried already:

  • I checked the NTFS permissions on the images directory.  I even added the same domain admin user explicitly to the folder and propagated change down that both the Stream/Soap service are using.
  • I blew away the old XML Exported Vdisk file and recreated it.  
  • I renamed the VHD and properties files to a few unique names.
  • I restarted Stream/Soap service and rebooted the entire PVS servers a few times.
  • I deleted the image name out of PVS console
  • Verified that the Stream/Soap service are using Domain account not Network or local service accts.
  • Neither PVS server will import the vdisk after copying it local. 

Please hit me with some ideas I am out of things to try.  

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...