Jump to content
Welcome to our new Citrix community!
  • 0

DST Time not Synching


Peter Guido

Question

Since the change to DST we have the same problem as in thread http://forums.citrix.com/thread.jspa?threadID=283558. I followed the suggestions in the excellent whitepaper from neton (http://www.neton.ag/wp-content/uploads/2009/02/fixing-the-daylight-saving-time-issue-in-citrix-provisioning-server-environments-v1-1.pdf). So far so good.

But what seems to be strange for me is:

When I start my vdisk image in private mode time is not in sync (1 hour behind, no dst). Net Time shows that DC01 is responsible for time settings. Time on DC01 is correct and the switch to dst run perfect for all servers an physical clients. So NTP configuration seems to be ok.

Now I sync the time on my vdisk image in private mode
w32tm /config /update
w32tm /resync

Time syncs and shows the correct DST now.

After the next reboot of the vdisk image, time is DST is "gone"!

Xen-Server shows the correct time as well and are configured with the same ntp servers.

Wy is it not possible to save this time config in private mode? Where else is this unsynched time comming from?

Edited by: Peter Guido on 28.03.2012 02:20

Link to comment

11 answers to this question

Recommended Posts

  • 0

Hi,

I had a similar issue and I looked at DST most of the day, I think this was the root cause but it wasnt the fix for me.

I came in yesterday morning to find lots of Unregistered machines showing in Desktop Studio, I tried to logon to them through the Console and it was reporting errors connecting to the Domain and the time being out.

I tried to edit the vDisk in Private mode since the clocks went forward but it made no difference at all.

Additionally the Unregistered machines were constantly restarting and everytime they did the clock sprung forward an hour, eventually I logged onto one machine as local admin and the clock was showing 16:00 hours on the 31st March.

All very odd.

Anyway without going into too much detail I marked the devices as Down in PVS Console and Reset Machine Account Password through the the Console. After a Reboot of the Machines they came back registered and subsequent reboots they were still registered and ready for connection. These machines are Power Managed and 50% of them are set to be turned off over the weekend when the clock change happened, I can only assume when they came up the time was incorrect and it failed to syncronise back with the DC and eventually lost its domain registration.

I hope this helps you, I did a 17 hour shift trying to resolve it and I spent most of my day looking at DST.

Chad

Link to comment
  • 0

Time zones were correct on all xen servers, but I had to sync the hwclocks, thanks for the hint. I have also tried to reset machine account passord. Unfortunately that did not fix the issue.

Attached are some pictures with eventlog entries, to give a more detailed view to this issue. VM was started at 13:44 with vdisk in private mode.

Picture 1.png shows when was starting on 12:48 (1 hour behind). In the general tab (Allgemein) it shows 2012-03-28T11:48:42

Picture 2.png shows that a few secons later, time changes to 11:49 (from 11:49 to 10:49 in general tab)

Picture 3.png shows another few seconds later, time changes again to 12:49 (10:49 to 11:49 in general tab)

Picture 4.png shows system time before resync

Picture 5.png shows system time after resync

Now we would have the correct system time. After the next reboot it is gone. On all other machine types, like virtual servers, physical servers, physical clients, hosted vm's etc. time synching works as expected. We only have this issue on provisioned vdisks.

It looks like it is calculating time from UTC. We are located in Switzerland (GMT+1).
Edited by: Peter Guido on 28.03.2012 09:32

Edited by: Peter Guido on 28.03.2012 09:33

5.png

4.png

3.png

2.png

1.png

Link to comment
  • 0

I have found setting the time in BIOS first, then synch with your time source at the host level second, then set your guests to get time from the host, at least where you can like on VMware.

The DST time issue for PVS should be better documented under edocs.

Link to comment
  • 0

Hi,

We seemed to have got this stable now.

I had to provision a new vDisk after the time change the weekend previous and also reset the Machine Account Password or Recreate the Machines, either method seems to have worked for us. There were lots of errors on the DC about the machines not being able to contact the Domain and likewise on the Clients trying to connect.

We were seeing the following Events on the Domain Controllers;

"The session setup from the computer <COMPUTERNAME> failed to authenticate. The name(s) of the account(s) referenced in the security database is <COMPUTERNAME>$. The following error occurred:

Access is denied.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp."

It appears what was happening was the machines were starting up and were an hour behind due to the Virtual Disk being created before the time change, this then attempted to synchronise time with the Domain Controller and failed, this machine was then not registering with the domain controller.

Regards,

Chad Brindley

Link to comment
  • 0

Now I am sure, this issue is related to provisioning server. While I was creating a new vdisk, I had always an eye on system time. As long as the disk was part of the vm on Xen-Server, the time was correct. As soon as I have converted the disk to the vdisk on pvs, the system time was one hour behind. I have tried again to resync time (http://support.citrix.com/article/CTX123336, http://support.microsoft.com/kb/886516/en-us) and I also tried to create new accounts, no success. So I am still going on with the fix from neton. But it is just a workaround, because, sometimes all GPO are applied corecct and sometimes not and it's only because time is not in sync. Still no fix for this issue?

Edited by: Peter Guido on 11.05.2012 03:08

Link to comment
  • 0

Hi,

This issue for us is now resolved.

I think what happened was when the time changed the machines were turned off, when the machines came back up they were an hour behind the Domain Controller, could then no longer communicate and not gets its time from that source.

I simply had to provision a new vDisk from the Gold Image after the time change had occurred, additionally I had to reset the computer accounts through the PVS console.

This is not an automated fix by any means but it resolved the immediate issue we had.

Now I am unsure whether to try and put some automation in place to fix this in October or whether I put a process in place to provision a new disk post time change.

Chad

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...