Jump to content
Welcome to our new Citrix community!
  • 0

USB Foot Pedals - what works in a pure XenApp 6.5 environment?

Peter Carter1709152533


We are rolling out XenApp 6.5 to our users, and many of them are home transcribers that will need to use USB Foot Pedals.

We currently use the VEC Infinity IN-USB-2 USB Foot Pedal, but this device is not coming across to XenApp 6.5 hosted applications that it will need to interact with. It is a very basic device and requires no special drivers - it is truly plug-n-play on XP, 7, 2008 R2, and probably more. You plug it in and it shows up as a basic input device and works great with the application so long as the application is on the actual client machine. But through Citrix, the foot pedal simply doesn't work at all.

Out Citrix rep told me USB devices will either work or they wont and there's not a whole lot Citrix can do to get them working as it relies on Microsoft architecture to do the re-direct. He recommended diving in to VDI with XenDesktop but our organization is just not there yet. We need to get USB foot pedals working on pure XenApp 6.5.

So a few questions: What foot pedals do you guys use? What foot pedals are supported? Can I possibly get the IN-USB-2 model that we currently use to work somehow?

http://www.citrix.com/ready didn't show anything for supported foot pedals.


Link to comment

7 answers to this question

Recommended Posts

  • 0

Well found a bit more info that's leading toward a resolution. I ran the HDX experience monitor for XenApp and it says USB redirection is disabled via AD policy (see attached picture). I turned on the RemoteFX usb redirection policy on the xenapp session host server, did a gpupdate /force, and rebooted. But still the same error. I'm not sure if the client needs to have this policy enabled too, but that will be my next thing to try.


Link to comment
  • 0

Well the policy to actually turn this on is: "Client USB device redirection" which is a user policy turned off by default.

But this shows "Applies to XenApp 6.0 or later (VM Hosted Apps) and XenDesktop 5.0 or later. We are not doing VM Hosted Apps or XenDesktop yet, but we do have a ticket in with Citrix so I will reply to this thread with what we decide to do.

Link to comment
  • 0

Citrix support pretty much told us the same thing as our rep in that there's not much they can do to get it working over pure XenApp. They said it boils down to the type of re-direction over XenApp VS XenDesktop, and XenDesktop has way better support for it whereas XenApp is a more limited re-direction.

There are a few options one could possibly go:
- Publish the app as streamed to client if you can. This worked for us on 1 app, but another app we need that requires foot pedal support uses IE & an active x plugin, so streamed to client isn't an option for that as you can't stream IE to the client.
- VM Hosted Apps (Host the app off of a XenDesktop VDI which supposedly works)
- Pure XenDesktop... if you can

We have a serial/COM port foot pedal on order to try because apparently there is much better support for serial. If this works we will go that route until our organization is ready to dive in to the world of XenDesktop.

This has been such an annoyance. I wish Citrix would just find a way to provide the same USB support as they do on XenDesktop over XenApp too

Link to comment
  • 0

We came up with a solution. We purchased the XF-10-USB-R foot pedal which comes with software called MacroWorks 3 that allows us to program hotkeys. So when a user presses the middle button on the foot pedal it sends a certain key to the computer.

So in our case we programmed it to send CTRL+SPACE which is what our transcription software requires, and this sends that hotkey to the computer which obviously goes over Citrix to the application. XenApp never sees the USB device, but it doesn't really need to as it's just sending the keystrokes over to do the required functions like start/stop, rewind, fast forward.

Most transcription software has options to control what keys do what function... so you can tweak that along with MacroWorks 3 to get it working.

And MacroWorks 3 isn't required, it's just the software that came with our foot pedal so we will be using it. You could probably find something else... whatever works with your foot pedal.

Link to comment
  • 0

Have a look at https://support.citrix.com/article/CTX234916

On a Windows Client there is a registry key (HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICA Client\GenericUSB\DeviceRules) which denys some HDI Classes.

DeviceRules registry setting take precedent over Citrix policies in Studio, AD and Receiver.admx policies on the client computer.


After hours of searching and one hour remote session with citrix support i got pointed there.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...