Jump to content
  • 0

Disconnected desktop sessions sometimes won't re-connect with a "the active session limit has been reached" error.


Jason Mills1709152515

Question

I have been quite happily having my users switching between terminals within our office and between other offices and connecting to their Virtual machines with no issue. They can just disconnect at night and reconnect in teh mornings or from home.

Just recently one or two users have been getting an error like "the active session limit has been reached" when trying to re-connect to a disconnected session. As soon as we log the user off their disconnected session they can then connect to their desktop again.

I am not sure of the exact wording as it has only happened three times and I wasn't around to see the exact message.

I have done some searching and it looks like it may have something to do with session reliability but I can't seem to reproduce it easily and am wondering if anyone else has come across it and if so what is teh casue and more importantly the solution.

Thanks in advance

Link to comment

Recommended Posts

Unfortunately the hotfix is for XD5.5 only. I still see the problem in XD5.6 (freshly deployed, not upgraded) where the state is "disconnected" and a user is still assigned. I'm runing my sessions as VMs under HyperV and see the user is logged in with the screen locked when viewed with SCVMM. Can this occur with some sort of improper session termination?

Link to comment

Any resolution to this thread yet? I am in the same boat - XD 5.6 FP1 and this happens pretty regularly when people try connecting from different computers. This has been happening since 5.5 (that's what I started on). I have a lot of people that connect from home and then connect from a thin client or PC at work. Out of about 350 clients we get about a dozen of these in a weeks time.

Link to comment

We have a user who are having this issue as well. They are a Remote PC user (5.6 VDA / 5.5 DDC). They also frequently use Remote desktop while in the office and then experience the issue when trying to connect via Citrix and receive "You are not permitted to start any more sessions for this resource"

Edited by: lobocchiaroj on Jan 18, 2013 10:00 AM

Link to comment

@dhallenbeck - I think you might be on to something about the updates. A user reported the problem today after being patched the night before, prior to that everything was working smoothly. We are using XD5.6 FP1 with 5.6.300. I can't believe Citrix hasn't officially said anything about this issue since it appears to be pretty widespread and been happening for quite some time!

As other people have stated we can't seem to isolate why exactly it is occurring, but our users are definitely calling this a deal breaker. The only notable difference from everyone else on this thread is that we are not using a shared desktop pool, we have a one-to-one relationship meaning that only one person is assigned to one host. I really hope that someone has found a solution to this very annoying problem! Appreciate any help that can be offered.

Thanks,
Uriel

Link to comment

Has anyone ever found a solution to this problem. I'm using XD5.6 and am having this problem

Intermittently, users are disconnecting and are unable to reconnect.  We use wyse terminals, and after disconnecting when a user tries to reconnect, they login and after a few seconds the user is taken back to the loging screen.  I log the user off the DDC and they are able to connect with no problems after that.  it is random with some users and isn't happening to all users, but it happens enough that it's causing me problems.

Link to comment

Same issue here. As with all the others, the citrix fix does absolutely nothing.
I am using the WI and if I just close the web interface and the login page, I can not log back into the desktop until I manually reboot the desktop.

I found a reference somewhere to enabling UDP ports, but the post didn't expand upon that and I am not sure which UDP ports they were referring to.

I'm hoping to have some time to dig into this today. Setting the VM's to reboot every night would resolve the issue, but I really don't like clunky workarounds like that. I am hoping to find an actual fix.

Link to comment

can't find appropriate solutions at anywhere about this issue.

i want a official Answer of Citrix side

symptom is the same.
(DDC version = 5.5)

Details..
1. users could not connect their VMs
2. VM State = Disconnected (on Desktop Studio)
3. it occurs randomly (some users are NEVER, the others are Frequently)

Individually,
i think it doesn't work correctly about Session Management of DDC..
it's like a bug.. don't u think so?

cause.. i tried to fix/figure out this issue for a month..
but i couldn't find any log or problem at anywhere..
now, when it happens i got a only solution is reboot of VMs..

is there any possible reasons or solution to solve this issue?
i feel stuffy.. really wanna Answer..

Link to comment

Hi Marc,

We havent found a solution yet as such but we do have a work around which has minimised the problem. We found that if the users leave there session and it locks by itself or if they do a ctrl alt dlt and lock the workstation and then leave it say over night then the problem would occur quite often.

We got them to go start disconnect and then re-connect the next morning then it works fine. Seldomly we still get it occuring when a user moves from one terminal to another, but it is quite rare.

Even the first scenario only seemed to happen to a very small percentage of the users, though it was the same ones all of the time.

We tried new machines, new user profiles, new pools but still the same.

Sorry I don't have a definitive fix but hopefully this helps.

Regards

Jason

Link to comment

The issue has just happened again and it occurred when a user was switching from one thin client to another. Several users do this constantly day after day and several time's through the day.

The session shows up as disconnected in the desktop studio and the assigned user is still listed.

Unfortunately when I restart the machine it rebuilds it so I can't see anything in the event viewer or any logs .

Jason

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...