Jump to content
Updated Privacy Statement
  • 0

NIC driver for Windows PE


rudi schoeble

Question

We use ShadowProtect to do P2V conversions and test our backup & restore procedures. This involves booting a new VM using a Windows PE ISO image which then connects to a network share containing our backup image files and restores them to the new VM drives.

It works fine, however copying the backup image files is very slow. Once the VM is restored and Xentools is installed copying the same images is considerably faster. I suspect the NIC driver that the Windows PE environment uses may be the issue. The PE environment does provide the opportunity to load custom NIC drivers and I'd like to try the driver used with Xentools as a test, however I can't find a .inf file that the WIndows PE environment is looking for.

Any ideas on where or how I could obtain the NIC driver .inf file used by Xentools?

Thanks

  • Like 1
Link to comment
  • Answers 64
  • Created
  • Last Reply

Top Posters For This Question

Recommended Posts

  • 0

Hi, Rudi. If you use 7-Zip to open xensetup.exe on the XenServer Tools ISO, you will find the driver files (including INF). The network driver files should be the ones that start with "xennet" (see screenshot).
!xennet.png!

Let us know if you succeed in adding these to your Windows PE image (I'm curious to know myself). If your issue is resolved, mark the thread as answered and posts as helpful or correct.
___
{color:#555555}Kirk Kosinski{color} !http://www.linkedin.com/favicon.ico!
{color:#999999}MCITP: EA / VA / EDA7, VCP 4, CCA{color}

xennet.png

  • Like 2
Link to comment
  • 0

I have the same problem

wiht HP BL 460c G7 and Symantec Backup Exec System Recovery (Win PE, Vista) and 10 GB Emulex NC 553i

I have a support Call at Symantec but no solution.

to import the xen driver does not work, winpe loads the realtek driver, when i load de BUS - Bluescreen

The Problem ist only on the HP G7 Server with the 10 GB Emulex Cards, no Problem on HP G5

Edited by: awallne974 on 23.03.2011 04:22

Link to comment
  • 0

I'm also having exactly the same problem as awallne974, HP BL460c G7 running XS 5.6 FP1

Symantec (SRD) System Recovery Disk (Win PE) loads the Realtek driver and I'm unable to get connectivity.
I have tried the Xen drivers as suggest above to no avail and all listed HP drivers for the BL460 do not work.

Symantec support even created me a custom SRD without the Realtek drivers included but this also doesn't work.

Link to comment
  • 0

Dear Kirk,

You are right! These are the drivers we need. Thanks for that! But, sadly, it is no solution. Something is missing!

A normal driver-insert and -load on start process of the Windows PE Image (VistaPE/Win7PE) *don't make any advantage*. The NIC communication is very slow. It seems that the drivers are not totally load (Realtek are still active?)

I think some *Windows-Registry entries have to change additionally*. Maybe the Xen NIC-bridge has to be configured, or something else?

Kirk, do you have some information about that? Or maybe someone else has an idea?

Best regards,
b0mmel

Link to comment
  • 0

Hello, did anyone manage to resolve this? We're using Deployment Workbench to image VM's hosted on XenServer 6.0 with BL460c G7 hardware. It uses WinPE to to boot. Fails to connect to image share. When I bring up a command prompt I cannot connect to any shares on any server APART from share hosted on VM's on the the same XenServer host.
It's definitely a XenServer nic driver issue as we had similar issues with VM's we exported from our old XenServer 5.6 host (could not join domain, could not connect to shares) and only until we installed XenServer tools would it work.
I've tried to include the xennet drivers extracted from XenServer Tools in the WinPE image but no luck.

Thanks.

Edited by: Darren Friedrich on 12/10/2011 2:37 AM

Link to comment
  • 0

We're searching for a solution too. Till now we find out, that the issue is based on the Realtek network driver. All drivers you can download doesn't work, but the Realtek driver that is integrated/build-in in a SCCM WinPE by default works fine.

So it is more important for us to bring the PV driver for storage up and running, because without that driver the writing performance is very poor!

Best regards,
Stefan

Link to comment
  • 0

Hello everyone,

I am also trying to create a WinPE image with PV drivers inside.
It seems that only adding the drivers (offline using dism or online using drvload.exe) is not enough.
I have also made a compare file (using regshot before and after xensetup.exe /S /norestart ) and made the registry and file system changes, but I get an image which boots and hangs on "Starting Windows" (it's a 3.0 version - Windows 7 x86).

Any other ideas? It could save some time.

Thanks,
Cristi

Link to comment
  • 0

Hi Darren,

As I said, the image is loading, but it hangs on "Starting Windows" screen.
I have some other ideas, I'll let you know if I get a working WinPE with PV drivers.

The basic idea is to capture a WinPE image just after running xensetup.exe /norestart, but the only thing I'm afraid of : Windows 7 required a second reboot when I installed XenTools on Windows 7 Enterprise x86.

Link to comment
  • 0

Would also love to get this exe. As an extra note, I have installed a VM (Win7) into Citrix Xen Server (V5.6 or V6), and then loaded Xen Tools into that VM. I then used that VM to do a backup and restore of a second partition of that same VM, using Storagecraft V4.1.5, and I still got slow restores. I have eliminated any source slowness, and it is definitely just the way Storagecraft software talks to Citrix Xen Server, during restores. Another issue I am trying to prove/disapprove, is whether the slow restores are caused by the actual driver Citrix Xen Server uses for the Adaptec RAID controllers I am using (2402, 2405, 5405). When I install VMWare ESXi on that same hardware, my restores are 13x faster. (39MB/s vs 3MB/s). Any help will be appreciated. Will post further info when available.

Link to comment
  • 0

Today received latest Adaptec RAID drivers for Citrix Xen Server 6, from Adaptec, who was very helpful.

This is quite unlike my experiences with CISCO, who totally refused to help me get any firmware updates for my CISCO IP Phones, even though I was willing to pay for support. But that is another story.

Unfortunately, the new Adaptec drivers made no difference. So I am back to trying to get the LAN drivers from Citrix, who are also quite unwilling to help, as they claim this EXE is "untested", even though I was willing to accept the risk of an "untested" solution, and to test it myself. All this EXE really does is to swap a slow 100MB tested driver, for another faster 1GB driver, without rebooting - how risky could that really be?

To their credit, Storagecraft did help me tremendously, but this is an issue with the WIN PE 7 that Shadowprotect runs on. There even are drivers on the recovery CD for Citrix, but no matter what I do, it just keeps using the slow RTL8139 driver.

So, if anybody has that EXE, or can tell me how to force Shadowprotect to LAN the Citrix drivers, I will be most grateful. Please . . . . . . .

Link to comment
  • 0

Christi, thanks, have now obtained this elusive EXE. I am now working on implementing it.

This thread's original quest was to find a faster way of doing restores using Storagecraft Shadowprotect, which is based in Win 7 PE. This is what I want to resolve.

The only relevant file I found on the Storagecraft Shadowprotect 4.1.5 ISO is BOOT.WIM - is this the correct one to use with this Citrix EXE? Does anybody have a brief instructions on how to implement this EXE?

Will post instructions here when I succeed with this.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Footnote: If I look at the news on TV, I get sad for the world. If I look at these forums, then I have great hope for the world, with so many, clearly very clever people, willing to help, even novices like me.

Link to comment
  • 0

Just a note for people who have the installwinpe.exe

To successfully run from Windows 7 64 bit you need Visual Studio 2008 and Windows Automatic Installation Kit (AIK) version 3.0 for the exe to run successfully.

I have also noted the the wim file you attempt to inject the drivers with needs to be short name for example boot.wim or winpe.wim. I had one with a _ in the name and it threw up an error everytime I attempted to execute.

Link to comment
  • 0

Hello,

Has anyone who has used the installwinpe.exe to inject the PVS drivers into their winpe image had any issues with updating Xenserver tools?

My image blue screens bsod after reboot if I uninstall or reinstall the xenserver tools. During xenserver tools install (or uninstall) I get error "Failed to install drivers on one of the devices". This happens to the two nics I have installed.
If I go to device manager after install the NIC appears as unknown device. Reboot gives me a bsod.

Link to comment
  • 0

An ugly workaround. I was not able to get this to work with my provisioned image. So I had to go back to the Microsoft Deployment Toolkit deployment task sequence for my XenApp 6.5 installation.

After OS install I stopped the VM restarting by removing boot from hard disk in XenCenter.

Removed Network Interfaces from VM (I have 2)

Restarted VM then uninstalled XenServer Tools

Restarted VM which promptly blue screened then selected recovery mode when restarted from blue screen.

Allowed recovery to complete then restarted again and installed XenServer tools

Shutdown VM and readded Network Interfaces.

Now to see if it will allow me to apply Hotfix CPVS60E006 - For Citrix Provisioning Services 6.0 which was the reason I got into this mess.....

Link to comment
  • 0

Hi,

I received the installwinpe file from Darren (thanks again!) and have been able to inject the drivers into the .wim file. But upon boot (I'm running xenserver 6.1) I get a bsod telling me:
IRQL_NOT_LESS_OR_EQUAL
...
STOP: 0x0000000A (0x00000040, 0x0000001F, 0x00000001, 0x8C84D0F8)

Have anyone run into the same problem?
I got a gut feeling this can have something to do with miss-matching versions of xentools and xenserver? As the installwinpe package is 6.1x and the latest xentools drivers that comes with xenserver 6.1 is 7.0x. Or does that have nothing to do with it?

Regards,
Fredrik

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...