Jump to content
Welcome to our new Citrix community!
  • 0

Creating CIFS ISO Library SR fails


Brian Yerk

Question

Shared out C:\ISOs on the Windows 2003 Server server running XenCenter with full share/security permissions for everyone (to test why I cant connect)- even tried creating a separate admin user with full rights. No joy.

New SR > CIFS ISO Library > input \\myservername\ISOs

administrator/isouser/whatever always get the error-

"Creating SR
Unable to mount the directory specified in device configuration request.
Check your settings and try again"

Even tried creating a wide open share on another server. Any ideas?

Link to comment

21 answers to this question

Recommended Posts

  • 2

I have also faced similar issue when trying to mount a SR repo (CIFS/SMB) in a XS 7.0 pool, but failed to mount...

 

Error: Unable to mount (CIFS/SMB SR) the directory specified in the device configuration request

 

kernel: [11138903.811555] CIFS VFS: cifs_mount failed w/return code = -112 

mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

 

 

Later found that issue was with firewall settings in XS 7.0, so stopped firewall service (service iptables stop)

and then tried mounting the SR using the command...

 

 

xe-mount-iso-sr //192.168.0.30/Dump -o username=testuser,domain=test.com,vers=3.0,password=test01!

 

one wierd thing is that in the password field its not accepting ! when using the password= next to username=testuser, (command failed). so used the password parameter in the last field.

 

ver=3.0 refers to SMB version 3

 

  • Like 2
Link to comment
  • 0

What happens if you go to XenCenter, click on the XenServer (master, preferrable), click on the Console tab, and then hit enter ... the run: ping myservername

Also, are there any firewalls (even local ones on the Windows server) between the machine running XenServer and the CIFS host?

Edited by: Richard Colley on Nov 11, 2009 6:53 PM

Link to comment
  • 0

Ok, what is the result if you access a xenserver console and run the following commands:

mount -t cifs -o rw,mand,user=YOURUSERNAME //myservername/ISOs /mnt/
ls /mnt
umount /mnt

These 3 commands will connect to the share, list the files in the top dir, and then disconnect.

Does that work? (replace YOURUSERNAME and myservername with appropriate values)

If it doesn't work, what is the output?

Link to comment
  • 0

Hi again-

"mount -t cifs -o rw,mand,user=YOURUSERNAME //myservername/ISOs /mnt/" produces
mount error: cifs filesystem not supported by the system

Little confused because the guy who initally set up xenserver had said at one point he had gotten this to work but had to blow it away for some reason and start from scratch. He thought it was one of those silly little/something dumb kind of fixes....heh

Link to comment
  • 0

Is this XenServer 5.5? Is it a Citrix release, or some OEM version?

What is the output from this command on the XenServer console:

ls -l /sbin/mount*

Basically, the error you mentioned suggests that the software to connect to a windows share isn't installed. I have no idea why that might be.

If in the above output you see mount.cifs or mount.smbfs, then you can try something like this:

/sbin/mount.cifs -o username=YOURUSERNAME //myservername/ISOs /mnt

or the same with mount.smbfs instead.

Link to comment
  • 0

the mystery deepens but maybe this will help-

[root@XXXXX ~]# ls -l /sbin/mount*
-rwxr-xr-x 1 root root 22688 Jun 21 2008 /sbin/mount.cifs
-rwxr-xr-x 1 root root 17688 May 24 2008 /sbin/mount.ecryptfs
-rwsr-xr-x 1 root root 70484 Jul 31 2008 /sbin/mount.nfs
-rwsr-xr-x 1 root root 70488 Jul 31 2008 /sbin/mount.nfs4
[root@XXXXX ~]# /sbin/mount.cifs -o username=administrator //<server's-hostname>/iso /mnt

Mounting the DFS root for domain not implemented yet
No ip address specified and hostname not found
[root@SXXXXX ~]# /sbin/mount.cifs -o username=XXXXX //<server's-ip>/iso /mnt

Mounting the DFS root for domain not implemented yet
No ip address specified and hostname not found
[root@XXXXX ~]#

Link to comment
  • 0

and then-

[root@<server-hostname> ~]# mount -t cifs //<server-hostname>/iso /mnt/iso -o user=administrator
mount error: can not change directory into mount target /mnt/iso
[root@<server-hostname> mnt]# mkdir /mnt/iso/
[root@<server-hostname> mnt]# ls
iso
[root@<server-hostname> mnt]# mount -t cifs //<server-hostname>/iso /mnt/iso -o user=administrator
Password:
mount error: cifs filesystem not supported by the system
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
[root@<server-hostname> mnt]#

Link to comment
  • 0

and one more just because my head hasn't exploded yet- they seem to be mounted but xencenter can't see them and still fails mapping the cifs share

mount output
192.1.208.240:/ISOs on /var/run/sr-mount/2c11d203-d94a-c41c-03c3-061ce2bdadec type nfs (ro,addr=192.1.208.240)
192.1.208.240:/ISOs on /var/run/sr-mount/08a476b3-a90f-154f-607a-e0187d989265 type nfs
(ro,addr=192.1.208.240)

Link to comment
  • 0

The "mount" command is basically a wrapper that calls the filesystem specific mount. But mount.cifs also seems to require a different order of params. i.e. the -o xxxxx at the end of the line.

Try this command:

/sbin/mount.cifs //<server's-ip>/iso /mnt -o user=XXXXX

If you type /sbin/mount.cifs by itself, you'll see a fairly extensive set of options you can set. You might for instance, need (nb: no spaces between user,pass,dom options):

/sbin/mount.cifs //<server's-ip>/iso /mnt -o user=XXXXX,pass=yyyy,dom=zzzzz

Another tool you can use to help is smbclient:

smbclient --help
smbclient -L <server's-ip>
smbclient //<server>/iso -U <username>

Link to comment
  • 0

I had the same problem.

The problem came from my user with its password complexity !

If you read the article : CTX121937

Try to mount in command line the CIFS share. You'll see in command line if you can use some special caracters.

After modifying the password with a supported caracter, i've no problem to mount the CIFS share.

PS : you can use a full dns path or ip address, but not the host name without its dns suffix.

Enjoy.

Link to comment
  • 0

don't know if this will help anyone (or me) but wanted to toss it out here- something looks very wrong to me. looks like theres something wrong with the cifs module-

console 1
tail -f /var/log/messages

console 2
[root@<Hostname> ~]#
/sbin/mount.cifs //xxx.xxx.x.xxx/ISO /mnt/iso -o user=xxxx,pass=xxxx,dom=<Hostname>
mount error: cifs filesystem not supported by the system
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

console 1
Feb 26 11:11:01 <Hostname> modprobe: FATAL: Error inserting cifs

(/lib/modules/2.6.18-128.1.6.el5.xs5.5.0.498.1017xen/kernel/fs/cifs/cifs.ko): Unknown
symbol in module, or unknown parameter (see dmesg)
Feb 26 11:11:01 <Hostname>1 kernel: cifs: Unknown symbol CIFSSMBQueryReparseLinkInfo

***tailed dmesg and didn't see anything show up when repeating

Link to comment
  • 0

We were experiencing the same issue within a client's environment. After some thought, I went into the Active Directory and sure enough a GPO was enabled specifying NTLMv2 to be enforced by default. However, (obviously) the XenServer OS doesn't natively support NTLMv2. To work around this, try referencing the article below:

http://support.citrix.com/article/CTX123536

Edited by: Howard Mansbach on Jun 9, 2010 11:34 AM

Link to comment
  • 0

I had this same problem. After trying to mount through CLI, I got this error message:
mount error(12): Cannot allocate memory
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

Apparently you need to tell Windows that you want to use the machine as a file server and that it should allocate resources accordingly. Set the following registry key to ’1′:

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

and set the following registry key to ’3′:

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size

After making these changes and restarting, I haven’t seen this issue arise again. Fixed!
Taken from:
http://alan.lamielle.net/2009/09/03/windows-7-nonpaged-pool-srv-error-2017

Link to comment
  • 0

Try with IP if there is still a problem then try following.

I had been struggling this issue for long.

I finally able to make it work by enabling SMB/CIFS 1.0 feature enabled from windows features  which Microsoft has started sending disabled as default in windows10. 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...