Jump to content
Welcome to our new Citrix community!
  • WEM Agent v4.5 Upgrade Issues


    cugcblogs

    srinivasanshanmugamrnd.png.6fe6852beecfd95103de9a67e0924ce1.png by Srinivasan Shanmugam

    WEM Agent Upgrade from v4.3 to v4.5 – Issues

    WEM Infra, DB and console upgrade went fine without any issues. I ran into few issues when upgrading WEM agents, I have documented them.

    Agent Synchronization Issue:

    From WEM 4.5, LocalProcessOptimization history is consolidated into local database whereas in earlier it was a xml in local database location.

    When I tried to refresh cache after upgrading agent, got the below error.

    srini020218-01.png.307cf193953dd0daf9da59bd9a2eb1c5.png

    Local database files were not updated.

    srini020218-02.png.e31c2eb9eddae96d0c65cb9f7c7ba6cc.png

    Event log showed that LocalProcessOptimizationHistory table doesn’t exist in the local database. 

    srini020218-03.png.c549ef9b47e96f1b40b1f4a390e5faae.pngsrini020218-04.png.baa26ff9a6a6af05e1c016b9dfb2fff1.pngsrini020218-04-1.png.86ae3bfc4e7d30378bc5283916f803f1.png

    Stopped WEM Agent service.

    srini020218-06.png.b4117138db7fb999e823ff1fc8117a83.png

    Cleared the local database files from the server.

    srini020218-07.png.99b46831218c4c9f6024dbeee5ae5764.pngsrini020218-0.png.5f4152785d55dd484fada0a7b14a5d47.png

    Started WEM agent and NetLogon services. 

    srini020218-08.png.22d89623b0a4b761da8a35c9e4bf0e89.png

    After starting WEM agent service, local database files were created from Template DB files with same size.

    srini020218-09.png.d2b68a83fea4efed33bf196fc38867e4.pngsrini020218-10.png.3060576287dfae287a11d18535cca209.png

    Then I refreshed the cache, synchronization worked.

    srini020218-11.png?w=942

    Database files were updated. 

    srini020218-12.png.20b528dd8ab2c5f7635b987fc6ecaa1b.png

    Note:

    Local DB path for persistent machines -- C:\Program Files (x86)\Norskale\Norskale Agent Host\Local Databases

    PVS Targets -- WC Disk, in my case its D:\WEMCache.

    When clearing the local DB files on PVS targets, you need to do it on all the machines as it is stored in WC drive (which is persistent). I used ControlUp to stop the services on multiple servers and deleted old files. You might need to create a script to do the same.

    WEM Agents on servers’ part of Sites with RODCs:

    WEM Agent v4.5 either upgraded from v4.3 or direct install on servers’ part of AD Site with RODCs doesn’t work.

    When logging into server in RODC Site, I get the following error.

    srini020218-13.png.7da1bed1c57692c381aa7bb8d2b7cc7b.png

    When I checked event logs, I saw that Error while retrieving user token groups list.

    srini020218-14.png.109e936e32351bc022f1f4a13d07be29.png

    Then I opened VUEMRSAV.exe to check the logs. Environment Settings & Agent Settings were listed correctly but Applied Actions were empty. When I checked User Groups Membership, it was empty too. As WEM agent couldn’t retrieve user’s group membership it didn’t apply any actions.

    srini020218-15.png.9cad2baf3d2600a7a7de4a14027723bc.png

    WEM Agent Log from %userprofile%

    srini020218-16.png.0a592d975280bbde63ab843cf7136dfb.png

    When I uninstalled WEM Agent v4.5 and installed Agent v4.4, everything worked.

    Find below the behavior from Working server in a Site with writeable domain controller.

    srini020218-17.png.b13a3c70303493f19fc029def1275b57.pngsrini020218-18.png.6b241ebfa384cf586f063f391a34f6f5.png

    WEM Console issues:

    When users login to servers having WEM agent issues in RODC Site, it creates NULL entries for the users in WEM database. As a result, WEM console stops working more frequently with following error.

    srini020218-19.png.29dac5c3cdad98c7176d5a477973f4d2.png

    I had to run the following query and clear the NULL entries to resolve the console issue.

    srini020218-20.png.772ece9ccee43815a065854425d2af1a.pngsrini020218-21.png.1483862ed85b339bb13736975adfacf1.png

    Summary:

    So, I am running WEM agents v4.5 in writeable DC sites and WEM agents v4.4 in RODC sites. I have a case opened with Citrix, I will update you once I hear from Citrix support.


    User Feedback

    Recommended Comments

    There are no comments to display.



    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

×
×
  • Create New...