Jump to content
Welcome to our new Citrix community!
  • WEM 4.6 - Agent (Agent Name) is not Bound to any Configuration Sets


    cugcblogs

    alainassaf22rnd.png by Alain Assaf, CTA, Raleigh-Durham CUGC Leader

    Workspace Environment Management is one of the most exciting products recently acquired by Citrix. I’ve been testing and using the product since day one. I recently upgraded to Workspace Environment Management 4.6 and started seeing a lot of the following Event Log errors on my WEM infrastructure servers (in the Norskale Broker Service Event Log):

    assaf062818-01.png.01177844cd691715aa8e144366b08536.png

    I did a quick search and found the following article - After Upgrade to WEM 4.6 agents not getting configurations with error: Agent (Agent name) is not bound to any configuration set. If you are using Active Directory OU's in your configuration sets, this bug prevents any WEM agents from registering.

    I reached out to our TRM and received the private hotfix that addresses this issue:

    1. Stop the 'Norskale Infrastructure Service'
    2. Backup "C:\Program Files (x86)\Norskale\Norskale Infrastructure Services\Agent Broker Component.dll"
    3. Copy the replacement Agent Broker Component.dll from the private hotfix to "C:\Program Files (x86)\Norskale\Norskale Infrastructure Services"
    4. Reboot your WEM Infrastructure Server

    When I did this, the errors stopped. As the Support Article states, this issue will be addressed when WEM version 4.7 is released.

    Please ask questions and/or leave comments below...

    Take care,

    Alain


    User Feedback

    Recommended Comments

    There are no comments to display.



    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

×
×
  • Create New...