Jump to content
Welcome to our new Citrix community!
  • My XA/XD Workstation VDA Woes


    danschlimmernd.png by Dan Schlimme, CUGC Steering Committee

    I have been keeping everyone updated on my environment and wanted to take the time to update you with the most recent find/issue I ran into so that hopefully you do not run into the same headaches I did.

    As everyone may recall, I am currently running XenApp 7.6 with a number of site specific patches that were applied during our go live.  I am currently in the process of testing CU2.  You can catch up on my go live here My XA 7.6 Upgrade and PVS Implementation.  

    To be honest, it was a bit selfish and stemmed from our VPN connection cutting our bandwidth down to 1.5 mbs max.

    To give you a quick bit of info, when I remote from home, I typically connect with our VPN then remote into my Windows 10 PC so I of course wanted to start with my needs :)

    I wanted to be able to access my PC at work in a much quicker and more reliable method, so I decided to begin with setting up my PC for a Remote PC Connection.  If you are not familiar with this configuration, this is when you install the VDA onto a physical desktop/laptop and are able to connect to that device via an ICA session as you would a published application or a desktop that is created with PVS or MCS.  In short, it makes your device reachable from the Receiver or Web Portal.

    I wasn't sure if the steps would be different for adding a Remote PC to Studio so I first begin by following some great steps as always from Carl Stalhood to configure Studio for Remote PC.  Turns out, it was just as easy…

    Once Studio was configured, I installed the the XA 7.6300 LTSR Workstation VDA which Carl has provided the command line for (7.11).  I just went through the GUI without issue and the PC appeared in the Machine Catalog then in the Delivery Group.

    Great...Now time for testing...This is where the headache began…

    XA 7.6.300 LTSR VDA

    After the VDA was installed and I rebooted the device, I received an error of “The Handle is Invalid” when trying to authenticate into my PC locally with my domain credentials or even the local account I created in the event I get locked out of my domain account.


    This of course left me completely dead in the water.

    After much research I found that this is apparently a known issue Citrix Known Issues with Microsoft Security Updates for VDA 7.6.300/7.7.0 on Windows 10.  I booted my device to Safe Mode and looked for the updates listed and of course none of them were installed which left me even more dead in the water so I decided to uninstall.  Since I had no network, I was unable to uninstall the VDA which meant I needed to boot the device and have network.  

    To get around this issue, I had to turn to a trick I learned not too long ago.  I replaced the Utilman.exe with cmd.exe.  This would allow me to hit windows+u from the logon screen and get to the command prompt and uninstall.  

    Here is how I did that.

    1. Navigate to c:\windows\system32
      1. Rename Utilman.exe to Utilman.exe.bak
    2. Make a copy of cmd.exe
      1. Rename that to utilman.exe

    Now when you get to the logon screen and press windows+u, the command prompt will open

    XA 7.6.1000 LTSR CU1/CU2 VDA

    I then moved onto XA 7.6 CU1 and CU2 which both provided me a different result but it was the same for each.

    In this instance, I was able to log into the PC locally, but when launching the desktop from the Receiver or Web Portal, I got either a grey screen or constant circle as if the session was trying to connect to the PC.

    While the session was attempting to connect, I found that my PC was showing the desktop along with startup apps but I had no mouse or keyboard (sorry, no screenshot of this).  If I hit ctrl+alt+del locally, it would take me to the logon screen of my PC and end the ICA session.  On the other hand, if I hit ctrl+alt+del within the ICA session it would take my PC to the expected screen which clearly meant there was communication of some type.


    XA 7.11 VDA

    After about an hour on the phone with Citrix support, they were adamant that there were no known issues with any of the 7.6 VDA installs and I decided to simply update to the 7.11 VDA.

    I ran an in place upgrade of the VDA to 7.11, rebooted the PC and BAM, I was golden.

    I hope this was helpful to everyone!

    User Feedback

    Recommended Comments

    There are no comments to display.

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...