Jump to content
Welcome to our new Citrix community!
  • Configure Default Device Access Behavior with Workspace for Windows-Expanded


    raydavis22rnd.jpg by Ray Davis, CTA

    Some documentation isn't updated as fast as some would like. Citrix has a couple of sites that outline how to configure default device access behavior in Workspace for Windows. But as with any documentation, things change around technology, user needs, and security.

    I recently faced a challenge: Users wanted this prompt to go away, and only WebCams needed to be blocked.


    Now, I understand the user can click the option and say "don't remind me again." But our job in these roles is to make things transparent for our end users and clients to promote a good Citrix environment. I understand this sounds small, but in a high-security environment, it should be something that any Citrix person thinks about in the back of their mind. In my humble opinion, without proper configuration, it will give any product a sour taste to a user or client. Citrix Products (or really any products) take some heat from users at times. Citrix offers many configurations in its line of products. It's up to you as a System Admin or Consultant to do what you can to deliver a good experience.

    1. Navigate to the Citrix Article and download the ADMX files:
    2. Log in with your Citrix account and download

    The files will look like this:

    1. Drop these files in your \\domain.local\SYSVOL\lab.local\Policies\PolicyDefinitions
    2. Open up the Group Policy Management console and expand Citrix components. You will see the following:
    1. In my case, I disabled the 64bit settings, but you don't need to unless you are using it.
    2. I proceeded with disabling the Settings in the "Client selective Trust x64." The following screenshot shows the settings I disabled.
    1. In this situation, I defined the settings in "Citrix Client Selective Trust x86)."
    2. Enable the "Create Client Selective Trust Keys"
    1. For this specific setup, I was working on something for a client. They wanted things blocked, and the popups stopped.
    2. I went through these locations and selected:
      • Enable
      • 0: No access
        • specifying 0 for no access for all categories
        • File Security
        • MicrophoneAndWebcamSecurityPermission
        • PdaSecurityPermission
        • ScannerAndDigitalCameraSecurityPermission)
      • Also, do this in all zones:
        • oidInternetRegionIcaAuthorizationDecision,
        • oidIntranetRegionIcaAuthorizationDecision,
        • oidRestrictedSitesRegionIcaAuthorizationDecision,
        • oidTrustedSitesRegionIcaAuthorizationDecision
    1. The last setting you will need, if not already completed, is to add the URLS into the Trusted Zone.
    2. Computer configuration-> Administrative templates -> Windows Components -> Internet Explorer -> Internet Control Panel -> Security Page -> Enable "Site to Zone Assignment list" and add your company URL and put a number 2 in it.


    1. You can check the key as well by browsing here:
      1. Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Domains
    1. Now with those settings in place above, when a user opens a Citrix Desktop, you will notice that the Desktop viewer preferences are now set for the user.
    1. The settings will stop it from asking you. As you can see, they are set to "Do not connect me" The users can also change them if needed.
    1. At this point, the popups are gone. But the user still has control to change them if needed. If you wanted to prevent users from changing them for security purposes, you need to edit the registry location(on the client devices):
      • Here:

        Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICA Client\Client Selective Trust\oidPredefinedSecurityPolicySettings\InstantiatedSecurityPolicyEditable

      • Registry REG_SZ key is (Default)
      • Value is True by default. True means the users can change the settings.
    1. False means they cannot change them.
    1. You don't need the user to log out. It will update once the client gets the updated reg key location. But for safety measures, I would. You can also wait until the next business day or when new sessions start. It's your option, ideally.
    2. You can toggle them on or off in GPO with a computer login script on the client's or any option you may use in your enterprise environment.
      • Set-ItemProperty -Path "HKLM:\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICA Client\Client Selective Trust\oidPredefinedSecurityPolicySettings\InstantiatedSecurityPolicyEditable" -Name ‘(Default)’ -Value False
      • Set-ItemProperty -Path "HKLM:\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICA Client\Client Selective Trust\oidPredefinedSecurityPolicySettings\InstantiatedSecurityPolicyEditable" -Name ‘(Default)’ -Value True
    3. I am opening my desktop and will trigger something that will want to use my Webcams/Mic and Local drives.
    4. It's now greyed out as well.
    1. No file security pop up.
    1. Drive is not allowed to be accessed.
    1. Let's do a test with Zoom to see if it will trigger the Default Device Access behavior. No popup. In this case, the Zoom VDI plugin picked up the HDX Optimized channels and natively allowed the Mic.
    1. No USB options, as it's using the HDX optimized channel.
    1. To take it a step further, you can implement a Citrix Studio Policy to restrict some of this. Blocking the client's drives will never allow them to show up in the session.
    1. I had a request to Allow Mics only while blocking webcams. I must admit, this one was a challenging task.
    2. So I went back to the "Citrix Client selective trustx86" section and updated these keys:
    1. I logged into my VDA.
    2. Mic came in with no Device Behavior popup.
    3. The camera came in with no device popup.
    4. 1 out of 2 things is working. We know the CAM/MIC would come through. But I wanted to ensure no popup. Now I must figure out how to block the Web Cams for all.
    1. So I went into Citrix studio and found a Multimedia Conference Policy. I set it to Prohibited.
    1. Results are…. No video.
    1. Let's undo the Policy to ensure it will work again. This helps me confirm as well that what I did is working after all.
    2. After setting it to allow, the camera came back.
    1. I achieved the desired configuration by:
      • Setting the Client device keys to full access. Its' Number 2:FullAccess in the GPO
      • Disabling unusable configuration
      • Disabling Multimedia Conference Policy, which seemed to do the trick here for the cameras

    Hopefully, this will help someone, and as always, if you know something better. Please share 😊

    After all, Sharing is caring in my books.

    References used


    Click here to see more posts by Ray Davis, CTA!


    Are you a member of CUGC? Join today for free and get involved with your community!

    User Feedback

    Recommended Comments

    Hello Ray, Great blog post!! This is working great directly in the Citrix Workspace application with app launches. However in the web browser I am still getting the annoying security popups. I confirmed our Storefront site is in the trusted zone and have Enabled the “Site to Zone Assignment list”. In your experience does these settings work for both Citrix Workspace app and the Chrome/Edge browsers or just in Citrix Workspace?
    Link to comment
    Share on other sites

    They should work on both WEB and native application. Very Odd that it's not working for you.
    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Create New...