
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Consulting Solutions 

XenApp and XenServer - Better Together 

Overview 
One of the greatest aspects of XenServer Platinum integrated with XenApp is the possibility of having a single server 
image for all XenApp servers.  The administrative gains of having an environment similar to this are extreme as 
maintenance and management of a single image is much easier than managing hundreds of images. Plus, having a 
single image for all XenApp servers greatly reduces storage requirements for the XenApp farm.   

This Implementation Guide, which is in conjunction with three other deliverables
1
, demonstrates how to utilize a 

XenServer environment and allow for the provisioning of XenApp servers all within the same XenApp farm. The 
provisioning of a virtualized XenApp environment incorporates two distinct build phases with a trailing maintenance phase: 

¶ Phase I: Reference System Creation 

¶ Phase II: System Delivery 

¶ Phase III: Maintenance 

 

 

                                                           
1
 The Implementation Guide is one of 4 deliverables as part of the XenServer and XenApp ï Better Together solution. The 

entire set of materials is as follows: 

¶ Reference Architecture: Explains why a 100% physical architecture was reconfigured to include both physical and 
virtual systems. Covers a few of the deciding factors of why XenServer is the best server virtualization solution for 
XenApp servers. 

¶ Implementation Guide: A step-by-step guide showing how to incorporate a XenApp farm into a XenServer 
Platinum environment. Demonstrates how to create a golden XenApp image to be provisioned to a multitude of 
virtual machines.  

¶ Design Considerations: To meet the unique needs of the business, a solution like XenServer for XenApp allows 
for many different configuration options. This article focuses on a few of the major design decisions when 
integrating these solutions together.  

¶ TechTalk Webinar: Listen and learn why the XenServer and XenApp integrated solution is the best for enterprise 
environments. The webinar discusses justifications, design considerations and expectations.   

Implementation Guide 

XenServer 4.1 
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Phase I: Reference System Creation 
The initial goal for the integration of XenServer with XenApp is to create a base XenApp image. With proper configuration, 
this base XenApp image can host different sets of application when application profiles are applied to specific servers.  
Phase I of the implementation guide focuses on properly configuring the components to allow for the streaming of a 
XenApp server to XenServer.  This section focuses on: 

¶ Virtual Disk Preparation 

¶ Virtual Disk Creation 

¶ Virtual Disk Finalization 

Virtual Disk Preparation 
Virtual Disk Preparation 

 Screenshot Description 

1 

 

On the Provisioning Server, launch the Provisioning Server 
Console. 

¶ Select the Provisioning Server in the console: PVS1 

¶ Select File -> New -> Disk 

 

 

On the Select New Disk Type screen,  

¶ Verify the first option is selected: ñCreate a new virtual disk 
capable of booting a target deviceé.ò 

¶ Select OK 
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Virtual Disk Preparation 

 Screenshot Description 

 

 

The Add Virtual Disk screen will appear. This screen requests 
information about the soon to be created virtual disk.  Input the 
following information: 

¶ Virtual Disk: Create a new disk 

¶ Directory: F:\vDisk (This location is dependent on your 
implementation. The physical disk must have enough space 
available to support as the virtual disks) 

¶ Disk name: BaseXenApp 

¶ Disk size: 8192 

¶ Description: Base XenApp virtual disk 

Once the appropriate information is entered, select OK 

 

 

 

The virtual disk is being allocated on the physical drive. This 
process can take a few minutes.   

 

 

Once the creation of the virtual disk is complete, the virtual disk 
will appear within the console.  

¶ With the virtual disk selected, map the virtual disk as a local 
disk by selecting: Tools -> Map Virtual Disk. A lock image 
should appear on the virtual disk within the console.  

¶ Within explorer, a new drive should appear.  Double-click the 
drive and you will be prompted to format. Select Yes 

¶ Modify the defaults as follows: 

o Volume Label: BaseXenApp 

o Quick Format: Select 

¶ Select OK to erase the disk 

¶ When the format is complete, select the virtual disk within the 
Provisioning Server Console and select Tools -> Map Virtual 
Disk. The lock graphic on the virtual disk should have 
disappeared.  
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Virtual Disk Creation 
Virtual Disk Creation 

 Screenshot Description 

 

 

Within XenCenter console 

¶ Select the virtual machine, right-click and select Edit 

¶ On the Startup Options tab, reorder the Boot Order so 
Network appears first in the list  

1 

 

On the base XenApp image, insert Provisioning Server for Data 
Centers CD. 

¶ When the Provisioning Server Install menu appears, select 
Install Target Device for x86 Platform 

If the CD does not auto start, access the CD drive and double-click 
the ProSrv45_DeviceInstall32.exe file. 
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Virtual Disk Creation 

 Screenshot Description 

 

 

On the Welcome screen: 

¶ Select Next 

 

 

On the License Agreement screen: 

¶ Select I accept the terms in the license agreement  

¶ Select Next 

 

 

On the Customer Information screen: 

¶ Specify the following: 

o User Name: Specify an appropriate value 

o Organization: Specify an appropriate value 

o Install this application for:  Anyone who uses this 
computer 

¶ Select Next 
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Virtual Disk Creation 

 Screenshot Description 

 

 

On the Destination Folder screen: 

¶ Select Next 

 

 

On the Ready to Install the Program screen: 

¶ Select Install 

 

 

On the Installation Wizard Completed screen 

¶ Select Finish 

¶ Select Yes to reboot the server 
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Virtual Disk Creation 

 Screenshot Description 

 

 

The server should startup using the PXE client.  At the BIOS 
prompt, enter in the following information: 

¶ Device Name: Base XenApp 

¶ Description: Base XenApp Virtual Disk 

¶ Virtual Disk Assignment: 1 (corresponds to the virtual 
disk created in Virtual Disk Preparation section 

¶ Boot Preference: H (the virtual disk is empty and will not 
boot. This part will still boot from the local disk) 

This information populates the Provisioning Server database with 
a new target device. Looking in the Provisioning Server Console, a 
newly defined target device should be available. 

 

 

Once the server boots and the administrator logs in, the 
connection to the Provisioning Server can be verified by: 

¶ Looking in the system tray and verifying the Virtual Disk ï 
Active icon is available 

 

 

The virtual disk must be made available to explorer on the the 
XenApp server. Select 

¶ Select Start -> Control Panel ï Administrative Tools ï 
Computer Management 

¶ Select Disk Management 

¶ A volume is available but not assigned a drive letter.  Select 
the volume and select Action -> All Tasks -> Change Drive 
Letter and Paths 

¶ Select Add and pick an available drive letter (E:) 

The virtual disk is now available in explorer. 
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Virtual Disk Creation 

 Screenshot Description 

 

 

Acquire the Provisioning Server and XenApp Integration Utility 
from http://support.citrix.com/article/CTX116063. Extract the files 
locally on the XenApp server.  

¶ Launch the ñPVS PS Integration Utility.msiò 

¶ On the Welcome Screen select Next 

 

 

On the Version Selection page, select the correct version of 
XenApp (Presentation Server) 

¶ Citrix Presentation Server 4.5 

http://support.citrix.com/article/CTX116063
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Virtual Disk Creation 

 Screenshot Description 

 

 

On the Confirm Installation screen select Next 

 

 

On the Installation Complete screen, select Close.  

 

 

 

At this point, a new icon will appear on the desktop of the XenApp 
server called ñCPS 4.5 Integration Toolò.  This tool will prepare the 
XenApp server for provisioning.  

¶ Double-click the integration tool 

¶ Once the operation completes, a Success window will 
appear. Select OK.  

This process prepares the XenApp server for inclusion into the 
XenApp farm when it is started.  Integration utilities will execute 
when the administrator logs onto a new XenApp server. It is 
recommended that these scripts be executed with Group Policies 
or a local service.   
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Virtual Disk Creation 

 Screenshot Description 

 

 

The Device Image Builder screen appears automatically. Do the 
following:  

¶ Select the Optimize tab and verify all items are selected 

¶ Select the Destination Drive by selecting Browse.  The 
virtual disk should be selected (E:).  

¶ Select Build 

¶ Select Yes to confirm image build 

¶ Once the image build is complete, select OK 

This process is encapsulating the entire server into a virtual disk 
on the Provisioning Server.  
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Virtual Disk Finalization 
Virtual Disk Finalziation 

 Screenshot Description 

 

 

Within the Provisioning Server Console  

¶ Select the virtual disk and select File -> Properties 

 

 

Within the properties of the virtual disk 

¶ Select the Disk Mode tab 

¶ Change the Access Mode to: Standard Image 
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Virtual Disk Finalziation 

 Screenshot Description 

 

 

¶ Select the Options tab 

¶ Enable the following: Enable Active Directory Machine 
Account Password Management 

 

 

¶ Highlight the Provisioning Server 

¶ Select File -> Properties 
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Virtual Disk Finalziation 

 Screenshot Description 

 

 

Within the Provisioning Server Properties window 

¶ Select the Options tab 

¶ Select Enable automatic password support 
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Phase II: System Delivery 
Once the base XenApp image is created within the Provisioning Server system, the XenServer and Provisioning Server 
systems must be configured to provision the image to numerous virtual servers. This process includes the following steps: 

¶ Virtual Machine Creation 

¶ Provisioning Target Device Creation 

¶ Provisioned System Testing 

Virtual Machine Creation 
Virtual Machine Creation 

 Screenshot Description 

 

 

Within the XenServer Console 

¶ Select Server -> New VM 

 

 

¶ Select Citrix Presentation Server 

¶ Select Next 
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Virtual Machine Creation 

 Screenshot Description 

 

 

¶ Enter in a name and a description 

¶ Select Next 

 

 

On the Location screen, select Next 

 

 

On the Home Server screen, select Next 
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Virtual Machine Creation 

 Screenshot Description 

 

 

On the CPU & Memory screen, enter in the correct values and 
select Next 

 

 

 

On the Virtual Disks screen, select Next 

 

 

On the Virtual Interfaces screen, select Next 
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Virtual Machine Creation 

 Screenshot Description 

 

 

On the Finish screen 

¶ Unselect Start VM automatically 

¶ Select Finish 

 

 

 

Select the newly created virtual machine 

¶ Select the Storage tab 

¶ Select the Virtual Disk 

¶ Select Delete 

 

 

 

Select Yes for the warning message.   

Because the server will be streamed its virtual disk from 
provisioning server, there is no need for local storage. 

   

 

 

Select the Network tab and copy down the MAC Address 
(2e:b0:1a:96:15:70). 

The MAC address will be used to distinguish this virtual machine 
within Provisioning Server.  
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Virtual Machine Creation 

 Screenshot Description 

 

 

On the General tab for the newly created virtual machine, select 
Edit 

 

 

 

On the Edit General Settings 

¶ Select Startup Options 

¶ Move Network to the first item in the list 

 

 

 

Select the Optimization tab 

¶ Verify Optimize for Citrix XenApp is selected 

¶ Select OK 
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 Provisioning Target Device Creation 
Provisioning Target Device Creation 

 Screenshot Description 

 

 

On the Provisioning Server within the Provisioning Server 
Console  

¶ Select the Target Devices 

¶ Select File -> New -> Target Device 

 

 

Enter in the following information: 

¶ Name: This is the name as it will appear within Active 
Directory and within the Provisioning Server Console. 

¶ MAC: The MAC address should be the one obtained from the 
newly created virtual machine.  

When the information is entered, select OK 
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Provisioning Target Device Creation 

 Screenshot Description 

 

 

Under the Disks tab, select Change 

 

 

The Select Virtual Disk window appears 

¶ Select the virtual disk: BaseXenApp 

¶ Select Add>> 

¶ If a warning message appears, select Yes 

¶ Select OK 

¶ Select OK 

 

 

The target device must have its presence added into Active 
Directory.  

¶ Select the target device 

¶ Right-click and select Add target device to domainé 
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Provisioning Target Device Creation 

 Screenshot Description 

 

 

Within the Add to Domain window, enter 

¶ Domain Controller: Enter in the name of the domain controller 

¶ Organization Unit: Enter in the path to the organization unit.  
Start with the child OU first working up the tree to the root.  

¶ Select OK 

After hitting OK, a success response should be received. Looking 
on the domain controller, in the Active Directory Users and 
Computers console will show the target device being a member of 
the domain.  

 

 

At this point the target device within the Provisioning Server 
Console is linked with the virtual machine on XenServer via the 
MAC address.  When the virtual machine starts and requests its 
boot image from the Provisioning Server, Provisioning Server will 
stream the BaseXenApp image.  
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 Provisioned System Testing 
Provisioned System Testing 

 Screenshot Description 

 

 

Within the XenCenter console 

¶ Select the virtual machine just created and select Start 

¶ A successful PXE boot should be observed within the 
console window,  

¶ When the system boots, login using a domain administrator 
account 

 

 

¶ Launch the Access Management Console 

¶ Configure and run the discovery process within the console 

¶ Verify the provisioned server is located within the servers 
folder 
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Phase III: Maintenance 
With so many devices utilizing a single image, it is imperative that changes to the virtual disk happen in a structured and 
protected manner.  Updates should be tested in a pilot/staging environment and after approval they should be integrated 
into the production system.  This can be quickly accomplished by using the update virtual disk functionality within 
Provisioning Server by following: 

¶ New Virtual Disk Creation 

¶ Virtual Disk Modification 

¶ Virtual Disk Changes Integration 

New Virtual Disk Creation 
New Virtual Disk Creation 

 Screenshot Description 

 

 

On the Provisioning Server 

¶ Launch Explorer  and navigate to the location of the Base 
XenApp virtual disk image 

¶ Make a copy of the BaseXenApp image and rename it to 
BaseXenApp Update 

Note: You want to make sure the image is not in use when making 
a copy.  

 

 

 

Launch the Provisioning Server Console 

¶ Select File -> New -> Disk 
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New Virtual Disk Creation 

 Screenshot Description 

 

 

On the Select New Disk Type screen 

¶ Select Create a new virtual disk file capable of é 

¶ Select OK 

 

 

 

On the Add Virtual Disk screen 

¶ Select the directory where the virtual disks are stored 

¶ Select Use an existing disk and hit Select 
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New Virtual Disk Creation 

 Screenshot Description 

 

 

On the Select Virtual Disk window 

¶ Select BaseXenApp Update 

¶ Select OK 

 

 

On the Add Virtual Disk window 

¶ Enter in a description 

¶ Select OK 

The new virtual disk will be added into the Provisioning Server 
Console 
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New Virtual Disk Creation 

 Screenshot Description 

 

 

With the Provisioning Server highlighted 

¶ Select File -> Properties 

¶ Select the Options tab 

¶ Enable Check for new versions of a virtual disk 

 

 

With the BaseXenApp virtual disk highlighted 

¶ Select File -> Properties 
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New Virtual Disk Creation 

 Screenshot Description 

 

 

Within the Disk Properties window, enter in the following: 

¶ Class: XenApp 

¶ Type: Standard 

 

These entries will be used to distinguish different virtual disks to 
allow for automatic updating.  With a class of XenApp, one could 
create multiple variations of a XenApp server. During an automatic 
update, only virtual disks whose class and type match to update 
disk class and type are affected.  

 

 

 

¶ Select Disk mode tab 

¶ Select Enable automatic updates for this disk 

¶ Select OK 
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New Virtual Disk Creation 

 Screenshot Description 

 

 

In the Provisioning Server Console, select  

¶ Select BaseXenApp Update 

¶ Select File -> Properties 

¶ Enter in the following information: 

o Class: XenApp 

o Type: Standard 

¶ Select OK 

The update image is linked to the base image because the class 
and type are the same. 

 

 

 

In the Provisioning Server Console, select  

¶ Select the target device XA2 

¶ Select File -> Properties 

¶ Enter in the following information: 

o Class: XenApp 

o Type: Standard 

¶ Select OK 

The target device is now linked with the base image and the 
updated image for automatic disk updates. 
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 Virtual Disk Modification 
Virtual Disk Modification 

 Screenshot Description 

 

 

In the Provisioning Server Console, select  

¶ Select BaseXenApp Update 

¶ Select File -> Properties 

 

 

 

¶ Select the Disk Mode tab 

¶ Change Access Mode to Private Image 

¶ Select OK 
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Virtual Disk Modification 

 Screenshot Description 

 

 

¶ Select the Base XenApp target device. This device was used 
to create the initial virtual disk in Phase I 

¶ Select File -> Properties 

 

 

 

¶ Select the Disks tab 

¶ Update the Boot order to be Virtual Disk First 

¶ Select the Change button to remove the BaseXenApp virtual 
disk and add the BaseXenApp Update virtual disk 

¶ Select Ok 

¶ Select OK 

¶ Within the XenCenter console, start the BaseXenApp virtual 
machine used in Phase I 

This virtual machine will receive its image (BaseXenApp Update) 
from Provisioning Server, but it will be in private mode allowing 
changes to be made.  

  ¶  
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 Virtual Disk Changes Integration 
Virtual Disk Changes Integration  

 Screenshot Description 

 

 

Make the appropriate changes to the system. Because the system 
is in private mode, all images will be saved within the 
BaseXenAppUpdate virtual disk. 

Once the changes are complete, shut down the server and 
complete the following: 

¶ Select the BaseXenApp Update, select File -> Properties 

¶ Select the Disk Mode tab 

¶ Change the Access Mode to Standard Client 

Note: All items in the Disk Access Mode section must be identical 
between the two virtual disks being used in the update process.  

 

 

¶ Select the Identification tab 

¶ Update the version number of the updated disk to 1.0.2.  The 
updated virtual diskôs version number must be greater than 
the base diskôs version number. 

¶ Select OK 
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Virtual Disk Changes Integration  

 Screenshot Description 

 

 

¶ Right-click the Provisioning Server and select Check For 
Disk Updates -> Check for Updated Virtual Disks 

¶ A window will appear informing you that a update check is 
occurring. Select OK. 

Provisioning Server will look at all target devices Class/Type field 
to see if they match the base and updated disks.  In situations 
where they do, Provisioning Server will change the target deviceôs 
assigned virtual disk to the virtual disk with the greatest build 
number (BaseXenApp Update). 

Upon each target devices next reboot, they will be utilizing the 
latest virtual disk image. 




